FIXED FFGF3047LSF Frigidaire range oven not heating after using it for 90 minutes

shellebelle

Premium Member
Joined
Apr 5, 2015
Messages
7
Location
United States
Model Number
FFGF3047LSF
Brand
Frigidaire
Age
1-5 years
My oven has been working just fine - I've even made French macarons in it no problem just days ago (macarons are the first thing that will go wrong with a fussy oven). I made rolls in it last night, no problems. In any case, I baked some potatoes at 350 for 90 minutes today, and tried to use the oven again shortly after. The oven simply will not heat now - the user panel works fine, I can set the temperature and the control panel "clicks" as if to send the message to the oven, but then nothing happens. It is a gas oven, so there is no glow from the ignitor, sound of gas flow, or ignition. The broil function does not work either. The burners work fine.

I tried switching it off at the breaker for a few minutes, no luck. I checked the back of the unit and cannot find a thermal reset switch either.

This is so odd - it was working fine and then all of a sudden it's quit on me in the span of two hours. There are no error codes showing up on the display. Any help?
 
Last edited:

jeff1

Appliance Tech - Moderator
Staff member
Joined
Oct 10, 2004
Messages
23,708
Location
Ontario, Canada
Hi,

so there is no glow from the ignitor, sound of gas flow, or ignition.
That is the first place to start, check with a volt meter....is the ignitor getting power or not getting power when the control is set to operate the oven.

LINK> http://www.applianceaid.com/gas-range-repair-help.php#glow

No power there and the clock/control is suspect.
Power there but no red glow and the ignitor itself is suspect.

jeff.
 

shellebelle

Premium Member
Joined
Apr 5, 2015
Messages
7
Location
United States
I unfortunately don't have a volt meter, but fortunately have dealt with a bad ignitor in a previous oven so I'm familiar with the symptoms of those going bad. I'm suspecting the control board here because the oven has been completely fine up until I went to use it for the second time today - do those control boards simply just go bad in an instant?
 

jeff1

Appliance Tech - Moderator
Staff member
Joined
Oct 10, 2004
Messages
23,708
Location
Ontario, Canada

jeff1

Appliance Tech - Moderator
Staff member
Joined
Oct 10, 2004
Messages
23,708
Location
Ontario, Canada
Thankx for the update :)

jeff.
 
Top