• Please note, some of the links on our site are affiliate links (Learn More)

[FIXED] Dishwasher Random

jcnewbie

Premium Member
Joined
Apr 16, 2011
Messages
8
Location
Vermont
Model Number
MDB9600AWQ
Brand
Maytag
Age
6-10 years
My Maytag model MDB9600AWQ (QuietSeries 300) decided to act funny again.

The symptoms are that not all buttons work and the 2-digit LED display is totally off while dishwashing.

By "not all buttons work" I mean that "Auto Clean" and "Rinse Only" seem to respond but they always start a "Heavy Wash" cycle. The other buttons do not respond at all (or do not respond most of the time).

To diagnose which part needs replacement, I followed the Field Service Test instructions: Pressing the Heavy Wash key 5 times followed by the Start key within 6 seconds.

The result can be seen in this video:

Maytag MDB9600AWQ | JayCut

I suspect that the part that needs to be replaced is either the control panel Part# 99002795 or the control board Part# 12002710, but I am not sure which one.

Based on the symptoms you observe on the video, is it possible to pinpoint with high degree of confidence which part needs to be replaced?

Thanks.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,318
Location
McMullen Valley, Arizona
Hi,

It would be the control panel you'd need to replace.

The manufacturer has replaced part number 99002795 with this item, part number 6-917721.

Here's the control panel for your model you can order here:
Manufacturer's Number: 6-917721


Jake
 

jcnewbie

Premium Member
Joined
Apr 16, 2011
Messages
8
Location
Vermont
It would be the control panel you'd need to replace
Jake, thank you very much. Are you sure it's the control panel that needs replacement?

I replaced the control panel only 3 years ago (after the Start button stopped working). It seems strange that the same part fails so frequently. Please advise.

Thanks.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,318
Location
McMullen Valley, Arizona
Yes, whenever someone says not all buttons work then its always a bad control panel.

Its not uncommon for these control panels to go bad. The hot steam from the dishwasher usually causes it, your water heater may be set to hot, as the dishwashers heating element will raise the water temp. good enough.

Whats your home water heater set at? Normal would be 120-125 degrees.

Jake
 

jcnewbie

Premium Member
Joined
Apr 16, 2011
Messages
8
Location
Vermont
Belated thanks for your advice which turned out to be 100% correct. I replaced the control panel and the dishwasher came to life again (water temperature, by the way, was set to 120 degrees).
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,318
Location
McMullen Valley, Arizona
Excellent, good job, glad to hear that.:)

Thanks for the update.

Jake
 
Top