• Please note, some of the links on our site are affiliate links (Learn More)

[FIXED] Dispenser not working

jafer

Premium Member
Joined
Aug 26, 2009
Messages
13
Location
CHICAGO
I have a KSRG25FKSS04 Kitchenaide side by side Ref/Freezer. My ice dispenser just suddenly stopped working. The water dispenser works fine. The ice maker is making ice.

I openned up the front of the dispenser but really don't know what to look for.

As a side note, this started happening after my freezer suddenly defrosted. I followed one of your threads that indicated that the start relay/device was faulty. I took out and shook and it rattled. I am going to purchase the new part.

Do you think maybe when all the ice melted it might have fried the electrical board on the ice dispenser?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,755
Location
McMullen Valley, Arizona
Do you think maybe when all the ice melted it might have fried the electrical board on the ice dispenser?
No, Not that I've ever seen before.

As a side note, this started happening after my freezer suddenly defrosted. I followed one of your threads that indicated that the start relay/device was faulty. I took out and shook and it rattled. I am going to purchase the new part.
Yes, then that start relay on your compressor is bad.

Go ahead and replace it and give it 24 hours and then see if everything is working fine again.

Here's the start relay for your model:
Manufacturer part number 8201786 is RepairClinic item number 1177466
8201786


Let us know what happens.

Jake<!-- / message --><!-- sig --><!-- / message --><!-- sig -->
 

jafer

Premium Member
Joined
Aug 26, 2009
Messages
13
Location
CHICAGO
Still doesn't dispense ice

Jake,
Ice dispenser still doesn't work. Do you have other ideas/advice?

Thanks:(
 

jafer

Premium Member
Joined
Aug 26, 2009
Messages
13
Location
CHICAGO
Replaced Start relay

I forgot to mention that I did replace the start relay and ice dispenser still doesn't work. Other ideas?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,755
Location
McMullen Valley, Arizona

jafer

Premium Member
Joined
Aug 26, 2009
Messages
13
Location
CHICAGO
I openned up to replace motor and discovered that one of the wires was broken. Do you know which part and how to replace the wire or do I just try to solder back?:(
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,755
Location
McMullen Valley, Arizona
One of the wires on the electrical connector that snaps on the dispenser motor?

Jake
 

jafer

Premium Member
Joined
Aug 26, 2009
Messages
13
Location
CHICAGO
yes. A red wire was loose from the white 6-wire connector when I was disconnecting the motor from the wires.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,755
Location
McMullen Valley, Arizona
Can you put it back in place? Some had pin tabs you can bend out a bit so it says in secure.

Jake
 

jafer

Premium Member
Joined
Aug 26, 2009
Messages
13
Location
CHICAGO
no, the wire just snapped off the pin tab. So I can't put it back. Do you know the part number for that wire harness?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,755
Location
McMullen Valley, Arizona
Yes it is James.

Jake
 

jafer

Premium Member
Joined
Aug 26, 2009
Messages
13
Location
CHICAGO
Wire harness

Jake,

I finally got the wire harness but it seems different. There are only 4 cables connecting to the motor. Also, it does not have the female connector. It has male connector for the motor. Did I order the correct part #2206178 item number 826922?

Also, if this is correct part, can you point me to proper steps to dismantling old and replacing with new.

Thanks,
James
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,755
Location
McMullen Valley, Arizona
Hi James,

It shows to be the correct wire harness for your model. I've never had to replace this particular one before.

From the diagram it looks like you just pull it up from the top hinge, its #13 here:
ZKABSHXC.gif


Jake
 

jafer

Premium Member
Joined
Aug 26, 2009
Messages
13
Location
CHICAGO
Jake,

I finally got the correct wire harness for my freezer and after I replaced the wire harness, the ice dispenser was still not working. Luckly I still had the motor you suggested I replaced. I did so and it works like a champ.

Thank you SO much for your help!!!!!!!!!!!:3::3::3::3:
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,755
Location
McMullen Valley, Arizona
Excellent James, good job.:)

Jake
 
Top