• Please note, some of the links on our site are affiliate links (Learn More)

FIXED FPRU19F8RFC Won’t cool or stay cold. Some Ice on Evap coil

Tahoen4u

Premium Member
Joined
Jul 2, 2021
Messages
5
Location
TN
Model Number
FPRU19F8RFC
Brand
Frigidaire
Age
1-5 years
I have a FPRU19F8RFC that won’t cool. The fans are all working, door seals are fine, clean coils etc. I took the panel off inside and noticed frost on the evaporator coil. Picture attached.
Temperature stays around 58 degrees. Sometimes goes down to high 40’s but if I open the refrigerator it goes back up to 58 quickly. Unplugged for a time and replugged in same situation after a while.

Can someone point me in the right direction. Have a multi meter not sure how to use it but I can figure it out.
please let me know any other information you need.

Thanks
Tony

694E5EF2-51DD-4A39-83AB-416B67A97CB3.jpeg

 

Dan O.

Appliance Tech
Staff member
Joined
Oct 9, 2004
Messages
4,365
Location
Ontario, Canada
The coil should frost evenly across its whole surface.That is a sign of a refrigeration system problem. That could be a defective compressor, lack of refrigerant or an ubstruction in the refrigeration tubing.

It will require a trained refrigeration technician to look into it further. If the compressor is the problem it may not be cost effective to have repaired unless you have an extended warranty.


Dan O.
 

Tahoen4u

Premium Member
Joined
Jul 2, 2021
Messages
5
Location
TN
Thank you. I tested the defrost heater and defrost thermostat and both were good. I appreciate your time.
 

Tahoen4u

Premium Member
Joined
Jul 2, 2021
Messages
5
Location
TN
I also tested the temperature of the condenser. I read somewhere it should be close to 30 degrees above ambient. It is about 10 degrees above. I guess I am in the sealed system problem world.
 

Tahoen4u

Premium Member
Joined
Jul 2, 2021
Messages
5
Location
TN
Thank you all for the help. Calling to get an estimate. Only three years old and might be worth a shot. I live in middle TN and not so many repair places want to come out this far to give estimates. Have a good day.
 

Tahoen4u

Premium Member
Joined
Jul 2, 2021
Messages
5
Location
TN
Came out diagnosed it as the evaporator. Service charge was 150.00. Came back replaced the evaporator, added a die pack(think that’s what he called it). Checked out rest of system said all is working well. Charged me 450 for the install, freon; evaporator, dye pack and rest of supplies. Back in operation. So far so good.
 
Top