• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Frigidaire Electric Range FEFL79JBA - Oven will not heat

Tuscy38

Premium Member
Joined
Nov 2, 2021
Messages
3
Location
PA
Model Number
FEFL79JBA
Brand
Frigidaire
Age
More than 10 years
Hello,

After a cleaning cycle and thorough cleaning of our Frigidaire Electric Range we used our oven one time to make Pizza (bake set to 500F) and it has not worked since. The stove top works with no issue. To clarify neither the bake, nor broil element will get hot at any point.

I have done/checked the following:
Confirmed 240 volts to the terminal
Broil element - visual inspection and resistance checked (~16ohm)
Bake element - visual inspection and resistance checked (~16ohm)
Temperature sensor - resistance checked (~1000 ohms at 70F)

I believe I have bad relay on my control board but before spending $250 on a non-refundable part is there anything else I can do to confirm I have bad control board? If it is the control board wouldn't it throw an error code?

Any help would be greatly appreciated.

Thanks in advance.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,675
Location
Redmond, Oregon
Yes, the problem is the clock oven control board has gone out.

If it is the control board wouldn't it throw an error code?
Nope, not on this model.

Here's the clock oven control board for your model:
frigidaire-clock-timer-316462868-ap4356478_01_l.jpg


Let us know how it goes.

Jake
 

Tuscy38

Premium Member
Joined
Nov 2, 2021
Messages
3
Location
PA
Thanks Jake, I'm picking up the part today. I'll let you know how it goes.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,675
Location
Redmond, Oregon
Ok sounds good.:)

Yes, keep us posted.

Jake
 

Tuscy38

Premium Member
Joined
Nov 2, 2021
Messages
3
Location
PA
Sure enough it worked!! There was evidence of a short where the lower bake element connects to the board. That connector is a little charred but I double checked for continuity before proceeded and all seems good. If you look closely at the orange wire in the center you can see the charred plastic just below the black relay. I will be replacing the connector as soon as they get it in but were good to go! Thank you again for your help!

IMG_2212.jpg
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,675
Location
Redmond, Oregon
Sure enough it worked!!
Excellent @Tuscy38 , glad to hear the new clock oven control board fixed it.(y)

Thanks for the update!

If you look closely at the orange wire in the center you can see the charred plastic just below the black relay. I will be replacing the connector as soon as they get it in but were good to go!
Yes, I do see that. I've seen that on a few of my local service calls as well throughout the years.

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top