• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Frigidaire FFET3026TSC Double Oven F43 error

ElectroChris

Premium Member
Joined
Nov 9, 2022
Messages
6
Location
East Texas
Model Number
FFET3026TSC
Brand
Frigidaire
Age
1-5 years
I've done some research on this. The F43 error indicates that the EOC is not detecting the proper fan speed for the cooling fan. I've gone into test mode and determined that the EOC is reading a 0 RPM fan speed. I'm looking at the schematics and cannot find any wiring or notation of the tachometer circuit.

The replacement fan, an 318575603, does not seem, in any pictures, to have a tachometer connection. I would like to test continuity on the connections before replacing the fan and EOC.

Has anyone any documentation showing that circuitry, or is the RPM somehow fed back through the power circuitry?
 

ElectroChris

Premium Member
Joined
Nov 9, 2022
Messages
6
Location
East Texas
More data - the F43 error is for the top oven. When we set it to bake, it tries for 15 seconds then throws this error and stops.
 

ElectroChris

Premium Member
Joined
Nov 9, 2022
Messages
6
Location
East Texas
Even more info - we bought the oven, heavily discounted, at Habitat for Humanity. It is in brand new condition - nothing ever cooked in it. But a little banged up. I presume it was installed, had the issue out of the box, was returned to the store then donated to HFH. The top oven has never been used, except my wife is storing pans in it. But with Thanksgiving approaching she is becoming very irritated/insistent/ even mad that this has not yet been fixed.....
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,973
Location
Vicksburg Junction, Arizona
Sorry, we were unable to locate the tech data information and service manual for this model. Without that we are dead in the water.

Hopefully another Frigidaire tech. has seen this happen and can shed some light on it. Other than that, its best to contact Frigidaire support at 1-800-374-4432 and have a tech come out.

Jake
 

ElectroChris

Premium Member
Joined
Nov 9, 2022
Messages
6
Location
East Texas
Thank you, Jake! I have even more information. I disassembled the control panel and accessed the innards. Looks like the oven, while waiting for installation at it's prior home, had something spilled into the top of it. Looks like flooring glue. It got into the connectors on the relay board, and actually even corroded the IC chip legs. I think that is the problem. I have ordered a replacement relay board. I will report back when I get it installed.
 

Attachments

  • pcboard.jpg
    pcboard.jpg
    321 KB · Views: 30

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,973
Location
Vicksburg Junction, Arizona
Yes, you nailed it!

Here's the relay board for your model, in case others need it too:
Relay Board 316443913


Let us know how it goes.

Jake
 

ElectroChris

Premium Member
Joined
Nov 9, 2022
Messages
6
Location
East Texas
Thanks, Jake. Got the new relay board in and installed it this morning. Still an F43 error.

Since my last post I had wondered if the gooze had gotten into the connectors. I have had trouble finding the cable harness for this oven.
After I installed the relay board and got the error again I removed the relay board and the Control Board from the oven. I used my meter to test continuity on all of the cables and all of the cables seem to be passing their signal properly. That puts my mind at ease about the cables.

I have now ordered a new Control Board. I also have a cooling fan on order. Eventually I will have replaced all of the parts and the oven will work :)
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,973
Location
Vicksburg Junction, Arizona
Ok, yes hopefully the new clock oven control board and cooling fan motor will fix it, let us know how it goes.

Here's the clock oven control board for your model: Controller 5304513223

Here's the cooling fan motor assembly for your model:
318575612 Motor
 

ElectroChris

Premium Member
Joined
Nov 9, 2022
Messages
6
Location
East Texas
GOOD NEWS!!
The clock oven control board fixed the issue!! We are now cooking top and bottom! And in time for Thanksgiving!

My advice to anyone with this problem - change out the components one at a time till it works. Note - I did not replace the fan. It is still in the box.
Thanks for your help!!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,973
Location
Vicksburg Junction, Arizona
Excellent Chris, glad to hear the new clock oven control board fixed it.(y)

Thanks for the update and added information.:)
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top