• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Frigidaire FPBC2277RF8 upper ice maker not making ice

kilo95

Premium Member
Joined
Jan 9, 2020
Messages
8
Location
Green Bay WI
Model Number
FPBC2277RF8
Brand
Frigidaire
Age
1-5 years
Hello all. My ice maker in the fridge compartment slowly stopped making ice and then completely quit making ice. I still get ice in the lower ice maker, still get water at the door. There is small cubes in the tray in the upper ice maker.

Test 52C yields 27 deg F and 55c does fill the tray. Any suggestions on where I go from here? (I did use an external thermometer that showed 28 deg F in the ice maker.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,199
Location
McMullen Valley, Arizona
Hi,

27 degrees is too high, it needs to be 16 degrees or lower to make ice.

Do you hear your ice maker fan motor running?

I'm attaching your tech data sheet below, do TEST 57C that will activate the ice maker fan motor. Let us know if it runs or not.

Here's the ice maker fan motor for your model:
Cooling Fan 5304493604


Jake
 

Attachments

kilo95

Premium Member
Joined
Jan 9, 2020
Messages
8
Location
Green Bay WI
Also, how do you get it back out of test mode? I had to unplug it earlier to get it back out of test mode
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,199
Location
McMullen Valley, Arizona
Deactivate:
Press FF + for up to 10 sec. FFIM Diagnostic Mode will automatically deactivate after 5 min. of inactivity.
NOTE: Silence alarm.

Ok if the ice maker fan is running, then its either a bad defrost thermostat or bad defrost heater OR a sealed system problem if you have no frost on the ice maker evaporator coil.

Here's the defrost thermostat for your model you can order if yours ohm tests bad:
Defrost Thermostat 5303918810


Watch this video to ohm test it, make sure you unplug the refrigerator before you remove it to ohm test it:

Leave it in the ice water for at least 5 minutes before ohm testing it.

Here's the defrost heater for your model if yours ohm tests bad:
Defrost Heater Assembly 242094802


When you click the part link to the defrost heater you will see videos on how to ohm test the defrost heater and how to access/replace it.

Let us know what you find.

Jake
 

kilo95

Premium Member
Joined
Jan 9, 2020
Messages
8
Location
Green Bay WI
I will check tomorrow when I get home. If air flow was blocked in the lower freezer compartment, would that have any effect on the ice maker? I know my wife generally keeps the freezer slam full
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,199
Location
McMullen Valley, Arizona
If air flow was blocked in the lower freezer compartment, would that have any effect on the ice maker?
Yes, that would be possible.

Let us know what you find.

Jake
 

kilo95

Premium Member
Joined
Jan 9, 2020
Messages
8
Location
Green Bay WI
Thermostat shows no continuity after 5 min in ice water. Defrost element shows 192ohms. I can’t get the video to pull up saying what resistance it should show.
So, the thermostat is bad if I understand correctly. Is the defrost element showing bad also? I disconnected the element but did not remove it from the fridge. The photo is of the area around the element when I took the cover off. Completely frozen up 349F37D2-32CA-476C-9402-863B8E696AE6.jpeg
 
Last edited:

kilo95

Premium Member
Joined
Jan 9, 2020
Messages
8
Location
Green Bay WI
Also, once I put it back together from testing it, it started to make ice. I’m sure that’s only temporary
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,199
Location
McMullen Valley, Arizona
Ok, then the defrost thermostat is definity bad.

The defrost heater at 192 ohms seems too high, usually its good at 50 ohms or less.

So I'd order both the defrost thermostat and defrost heater to be on the safe side.:)

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,199
Location
McMullen Valley, Arizona
Ok, sounds good.

Jake
 

kilo95

Premium Member
Joined
Jan 9, 2020
Messages
8
Location
Green Bay WI
Replaced the thermostat and element. It has made a full bucket of ice now. Looks like it’s working. Thanks for the help!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,199
Location
McMullen Valley, Arizona
Excellent good job, glad to hear that. (y)

Thanks for the update!

Jake
 
Top