• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Frigidaire FPUS2686LF0 Crushed Ice Only

AM Appliance

Premium Member
Jul 26, 2021
Madison, WI
Model Number
More than 10 years
Hello, I have a Frigidaire refrigerator, side-by-side, manufactured 2010, Model #: FPUS2686LF0 and Serial #: 4A0360955. I was only getting crushed iced, never cubed out of the dispenser. The plunger of the crushed/cubed solenoid assembly (Part # 241675704) was no longer moving up and down freely as some noticeable corrosion was evident. However, once the new solenoid assembly was installed, there was still no cubed ice coming out of the dispenser. The metal arm was properly seated in the “elevator” portion of the solenoid assembly so that when the cubed button is engaged the solenoid is activated and lifts the plunger which lifts the metal arm attached to the ice bucket that moves a cover to allow for cubes to move freely away from the grinding teeth for crushed ice. This was simulated with door closed and with the door open with both door switches depressed to watch for solenoid activation. Then, a multimeter test shows there is no power at the terminals of the solenoid when the dispenser is engaged for cubed ice (with door switches depressed). From here I am attempting to see why power is not getting to the solenoid. Are there known issues with the display control board or main control board not getting power properly to the solenoid? Using the wiring diagram below I attempted to use J3-3 and J4-4 on the dispenser control board as a reference to power to the solenoid but what I recall as black and yellow wires led to a microswitch on the dispenser module assembly so I am not sure I am reading the wiring diagram correctly. After remounting the display control board and dispenser module assembly, a new issue arose with the auger motor no longer engaging at all when either cubed or crushed ice is depressed and the LED light above cubed is now off. My thought is to replace the dispenser control board but I am not entirely sure that will solve the entire issue. Are there any known issues with reasons why the solenoid might not be powered? Thanks much.
Check for 120 volts between J3-6 and J3-4 for the cubed/crushed Yoke which activates that solenoid to raise the ice bucket bar up for cubed ice. Make sure you hold the door switch in when you check those pins for 120 volts, also make sure its on CUBED ice selection and then press the ice dispenser lever and see if your meter reads 120 volts.

Then J3-6 to J3-3 is for the auger motor run, that should be 120 volts too.

If you get no voltage, that main power control board is bad.

Here's the main power control board for your model:
5304499076 Board-Main Power

For others following your thread--->It should be located underneath the refrigerator, watch the video below, it should be similar to where yours is located.

Let us know how it goes.
It was an unfortunate situation of replacing both electronic control boards without success. It wasn't until I replaced the module assembly and touch screen that all worked as it originally did.
I had great difficulty matching the wiring diagram to actual dispenser control board. J3-6 & J3-1 went to the LED board on the module dispenser assembly (part #242074223) and J3-4 & J3-3 went to the microswitch for the paddle.

I did replace the membrane you listed above and the module dispenser assembly 242074223.
Ok, thanks for clarifying that.(y)

Here's the dispenser module for your model, in case others need it too:
242074223 Module-Dispenser

Users who are viewing this thread

Support Our Site

If you feel that you have benefited from this site, and would like to show your appreciation, please consider making a donation.