• Please note, some of the links on our site are affiliate links (Learn More)

Frigidaire Stackable FFLG3911QW1 - Washer three beeps and when not in use

bedfordave

Premium Member
Joined
Dec 6, 2020
Messages
4
Location
New York
Model Number
FFLG3911QW1
Brand
Frigidaire
Age
1-5 years
Age unknown but the building the unit is in is ~6yrs old.

This is part of a stacked Frigidaire Laundry Center washer/dryer combo -- dryer seems to be fine.

The washer has been randomly stopping, initially beeping 3 times. It was then beeping varying amounts at random times over the course of days while not in use, and took us forever to figure out the washer was the source of the beeps.

I have also noticed that there is not always a beep when the cycle selection knob is turned. I cannot find a pattern.

Eventually after doing a full control reset, we can usually get it to operate more or less normally (I cannot tell if there is any confirmation that a reset has been performed, but I have followed the below instructions). However, at the end of a cycle you can hear plenty of water in the bottom if you move the drum (water is not typically visible).

I have tried entering diagnostic mode according to the tech data sheet (https://drive.google.com/open?id=11H7BbxLLIKfoAt95MMXEZl9wfdoWUc3y) but I never receive the one long beep that the instructions say indicates that diagnostic mode has been entered.

Any troubleshooting advice or suggestions would be very welcome. Thank you for your time!
 
Last edited:

bedfordave

Premium Member
Joined
Dec 6, 2020
Messages
4
Location
New York
Quick update: I realize now that I am an idiot and the sloshing noise is likely the balance ring.

The random cycle stops and unusual beeps, however, continue.

Thank you for any advice, and sorry to make such a silly mistake about the balance ring!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
115,889
Location
McMullen Valley, Arizona
I have not worked on this model as of yet, but I've been reading some other posts on this problem, you have 2 control boards, other members have found one of the control boards had burnt spots on them, and another found the connector pins in them have been coming out on the control board itself.

So I'd check both your control boards first and check the connectors to the control boards.

This is the main control board for your model:
5304511966 Control-Electrical


This is the motor control board for your model:
808653801 Board


Here's the service manual: https://drive.google.com/open?id=1lxpbkTUy65bViCI51K6mNYFSRL6dAKW0

Motor Control board is at the bottom of the washer, Main Control board is in the back. You will need to pull the front panel off and then pull the laundry center out from the wall. Look on Pages 141 Motor Control Board Accessibility through 144 where it says Main Control Board Accessibility.

Check all those wires down at the Motor Control Board to see if any are broken too.

Let us know how it goes.

Jake
 

bedfordave

Premium Member
Joined
Dec 6, 2020
Messages
4
Location
New York
Quick update -

Thanks for this Jake. I didn't see any visible damage to these boards, and will have a technician come take a look as the issue persists. I will update the thread once they let me know the issue!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
115,889
Location
McMullen Valley, Arizona
Ok Dave, sounds good.

Jake
 
Top