• Please note, some of the links on our site are affiliate links (Learn More)

FIXED FX510BGS/XAA Samsung Range Controls not Working

layers1

Premium Member
Joined
Jan 15, 2011
Messages
84
Location
San Antonio, Texas
Model Number
FX510BGS/XAA
Brand
Samsung
Age
1-5 years
I have a Samsung FX510BGS/XAA gas range. Everything has worked fine until about a 2 weeks ago, the cook top igniter stopped working, all 5 burners. I could still light them with a lighter, and everything else was still good. I did hear a noise from the range a few days ago late at night, and I thought there might be a rodent (mouse) somewhere in it and maybe an igniter wire had been chewed. My wife had the bright idea of turning all the top burners on and the broiler to fry the mouse inside, or at least run him off. Anyway it got hot, she turned the top burners off, and the the broiler would not shut off. The control panel was so hot I couldn't even touch it, but pushing it did nothing. I finally turned the breaker off. When I turned it back on the broiler remained off, the clock started a digital display 12:00, but the control panel would not respond anywhere. In a bit an error code -SE- was displayed, and now there is an occasional beep, but the control board does not respond. I tried unplugging, replugging - does not reset. The range top burners still will light manually, but of course nothing in the oven compartment, with the control panel inoperable. The oven light still comes on when the door is opened. Do I need a control panel, or is there a reset button? I would appreciate your advise. I do have electrical testers & meters, if there is a way to check it. Thank you, Larry
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
37,917
Location
Murray, Utah 84107, United States
Hi Larry, you have a short in the PCB or between the PCB and key panel cable (SE error code). Check the connectors first and if they check good, replace the PCB.
Control Board DE92-02588D
Control-Board-DE92-02588D--01657110.jpg
 

layers1

Premium Member
Joined
Jan 15, 2011
Messages
84
Location
San Antonio, Texas
Rick:

I replaced the PCB, no "SE" error code any more, the clock display is flashing & advancing, but there is no response from the key panel, so is the key panel & wire tape bad? I always appreciate your help.

Thanks, Larry
 

layers1

Premium Member
Joined
Jan 15, 2011
Messages
84
Location
San Antonio, Texas
Rick:

I left it plugged in and now about 10 minutes later, the range beeped 3 times & the "SE" error code is back displayed.
Help please

Thanks, Larry
 

wildimaginations

Appliance Tech
Joined
Jun 13, 2011
Messages
632
Location
Danville, California
You need to change the touchpad DG34-00018A The oven got so hot that it warped the plastic touchpad and is preventing you from making any changes on the controls.

As for the cooktop burners, you need to look in back and check the spark module to make sure you have 120 volts going to it. You may need to turn on one of the gas valves to send 120 volts to the module to check. If you get 120v at the spark module and no spark, replace the module.

Hope this helps.
 

layers1

Premium Member
Joined
Jan 15, 2011
Messages
84
Location
San Antonio, Texas
I really appreciate the help, but what is the part number for the spark module?
The number on the actual part doesn't match anything on the web, and I am getting conflicting numbers when I research it.

Thanks in advance, Larry
 

layers1

Premium Member
Joined
Jan 15, 2011
Messages
84
Location
San Antonio, Texas
Thanks a lot Rick
With the parts & repairing some chewed-up wiring, I am up & running now.
I probably didn't need the spark module, but that's OK
 
Top