• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GDF520PGJ2WW GE Dishwasher, no lights on front panel

F1173

Premium Member
Joined
Feb 21, 2021
Messages
17
Location
Knightdale
Model Number
GDF520PGJ2WW
Brand
GE
Age
1-5 years
Hello,

The dishwasher has power but nothing is lighting up and I can’t run a cycle.

Checked for 120 volts at VAC SUPPLY and has power.

Status light is STEADY ON.

Checked the connector J722 pin 2 black/green to pin 5 yellow/blue for 13V and nothing was showing on the multimeter.

Not sure what the next step is.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Hi,

That indicates the UI Board is the culprit.

Here's the UI(user interface) Board for your model:

When you click the UI Board part link you will see a video of how to replace it.

"NOTE--->When replacing UI control boards, the new UI Board MUST be configured as per the instructions included with the replacement. If the personality is not set by using the 4 jumpers, the buttons, LED’s or cycles will not function properly".

Let us know how it goes.

Jake
 

F1173

Premium Member
Joined
Feb 21, 2021
Messages
17
Location
Knightdale
Thanks for the reply, I read in some other posts that if there IS 14 volts when checking the J722 connector that it could be UI Board.

If there IS NOT 14 volts to the J722 connector can it still be the UI Board or maybe something else?

Just want to clarify before I buy the UI Board.

Thanks again for your help.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Checked the connector J722 pin 2 black/green to pin 5 yellow/blue for 13V and nothing was showing on the multimeter.
Sorry, my bad, I read that wrong. Correct, It should be 13.5 to 14 volts DC at the machine control board to the UI Board.

Snapshot_2 (1).jpg


Here's the machine control board(under the dishwasher) for your model: WD21X24900C

Jake
 

F1173

Premium Member
Joined
Feb 21, 2021
Messages
17
Location
Knightdale
Okay so even if the status light is showing solid green it can still be the main control board?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
On your model, yes that is correct.

If you are NOT getting 13.5 to 14.0 volts DC from the machine control board(underneath the dishwasher) on connector J722 pin 2 black/green to pin 5 yellow/blue, then your machine control board is the culprit.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Ok sounds good.

Yes, keep us posted.

Jake
 

F1173

Premium Member
Joined
Feb 21, 2021
Messages
17
Location
Knightdale
Jake,

Quick question, I am not getting any voltage from the wire harness connecting to the machine control board at J711. Is that a cause for a concern or change the diagnosis of a faulty machine control board?
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
You mean J722 on the machine control board no volts at all?

Like I mentioned in post #6--->If you are NOT getting 13.5 to 14.0 volts DC from the machine control board(underneath the dishwasher) on connector J722 pin 2 black/green to pin 5 yellow/blue, then your machine control board is the culprit.

Here's the machine control board(under the dishwasher) for your model: WD21X24900C
 

F1173

Premium Member
Joined
Feb 21, 2021
Messages
17
Location
Knightdale
I got that, but I was talking about the J711 pins. I found another post about ohm testing the pins for the door latch, where it comes into the machine control board. I was confused on that process. But I just went ahead and got the machine control board and if that doesn’t work I'll try something else.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Got it!

Here's the door latch switch for your model:
WD21X10490 Latch Switch


To Verify the door latch switch is good--->Follow the directions here:
LatchSwitch.png


Door closed: 0 ohms.
Door open: infinite ohms.

Let us know what you find. Make sure you disconnect power to the dishwasher before ohm testing.

Jake
 

F1173

Premium Member
Joined
Feb 21, 2021
Messages
17
Location
Knightdale
Jake,

I replaced the machine control board and it did not fix the problem. Dishwasher still has no operational lights and the LED on the machine control board is still steady on.

Is the UI board my next replacement option? Can I return the machine control board I just bought?

Thanks
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Checked the connector J722 pin 2 black/green to pin 5 yellow/blue for 13V and nothing was showing on the multimeter.

If you are NOT getting 13.5 to 14.0 volts DC from the machine control board(underneath the dishwasher) on connector J722 pin 2 black/green to pin 5 yellow/blue, then your machine control board is the culprit.

So we are still back to NOT SHOWING 13.5 to 14.0 volts DC from the machine control board(underneath the dishwasher) on connector J722 pin 2 black/green to pin 5 yellow/blue on that new machine control board? all the electrical connections plugged into it when you testing for 13.5 to 14.0 volts DC?

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
That's a very good video, that's exactly how to test for 13.5 to 14 volts DC on the machine control board.

In the video the meter showed 14 volts DC on pins 2 and 5 which means the machine control board is good, and the UI Board at the top of the dishwasher door is the problem.

If you got a good meter with a fresh battery in it you should read the same 13.5 to 14 volts DC like he did.

Make sure your meter is working properly by testing a 9 volt DC battery, bought from any store.


If your NOT SHOWING 13.5 to 14.0 volts DC from the machine control board(underneath the dishwasher) on connector J722 pin 2 black/green to pin 5 yellow/blue on that new machine control board, then the machine control board you got is defective.

Jake
 

F1173

Premium Member
Joined
Feb 21, 2021
Messages
17
Location
Knightdale
I installed the new UI board and ran a cycle and everything seems to be working normal.

I guess I need to get a new multimeter.

Thanks for all your help.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Excellent, glad to hear the new UI Board fixed it.(y)

Thanks for the update!

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top