• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GDF520PGJ2WW GE dishwasher will not start

RyanRei

Member
Joined
Sep 18, 2021
Messages
1
Location
Ohio
Model Number
GDF520PGJ2WW
Brand
GE
Age
1-5 years
I push the START button and the dishwasher beeps three times as if the door is open. I have replaced the door latch to see if that was the problem, but the dishwasher still beeps. Next, I checked the main control board to see whether the LED indicator light was flashing, steady on or steady off. I noticed the light is steady on with the door connector disconnected. However, I plugged the door connector into the control board, and the light flashes once every 1-2 seconds. Could you please help me figure out whether the control board is not working or if the issue is something else?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,333
Location
McMullen Valley, Arizona
Ok, that indicates the problem is the machine control board.

--->Here's the machine control board for your model you can order: WD21X24900

Let us know how it goes after you replace it.

Jake
 

Cindy406

Premium Member
Joined
Oct 5, 2021
Messages
3
Location
Kalispell, MT
I have this model and it was unresponsive, I replaced my machine control board as above, and it worked great for about 5 cycles now there are no lights in door and LED is steady on. Next steps?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,333
Location
McMullen Valley, Arizona
Hi Cindy, Ok, If the machine control board STATUS LED is STEADY ON--->UI personality not set, communications lost between UI and MC.

Here's the UI(user interface) Board you would need: WD21X23463 Kit Svc Ui Front Logic

The UI operational voltage is output from the machine control board on connector J722 pin 2 black/green to pin 5 yellow/blue. If 13.5 Volts DC is found here, then the UI Board is the problem.

Snapshot_2 (1).jpg


Connector J722 is located on the metal casing side of the main control board.

J722.jpeg


It's the one on the left above the ethernet port.:)

"NOTE--->When replacing UI control boards, the new UI Board MUST be configured as per the instructions included with the replacement. If the personality is not set by using the 4 jumpers, the buttons, LED’s or cycles will not function properly".

Let us know how it goes.

Jake
 

Cindy406

Premium Member
Joined
Oct 5, 2021
Messages
3
Location
Kalispell, MT
So I am not sure how to test the voltage so I will just order the part and hope, is setting the personality difficult?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,333
Location
McMullen Valley, Arizona
Ok, sounds good.

Here's the service manual instructions for your exact model:

You will need to remove the whole door, then separate the door, then remove the front control console, to replace the UI Board.

Here's the service manual for your model: https://drive.google.com/open?id=1XTOXM0wA0UJEuucW0deIni17sMPtDGtD

Page 26 Door Removal
Page 28 Separate Door
Page 29 Front Control Console Removal
Page 30 UI Removal

Let us know how it goes.

is setting the personality difficult?
Watch this video Cindy:


Jake
 

Robb S.

Premium Member
Joined
Oct 18, 2021
Messages
3
Location
Virginia
Hi. Same model. Same problem. Removed control panel and light steady off. To be honest, I didn't even notice a light to go on and off, but maybe it's just not visible when it's not on. Any advice? Thanks.
 

Cindy406

Premium Member
Joined
Oct 5, 2021
Messages
3
Location
Kalispell, MT
I am please to say I am up and running! I was way over thinking the process to change out these two parts! Great instructions! clean dishes!!!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,333
Location
McMullen Valley, Arizona
Hi. Same model. Same problem. Removed control panel and light steady off. To be honest, I didn't even notice a light to go on and off, but maybe it's just not visible when it's not on. Any advice? Thanks.
Hi Robb, that indicates the problem is the machine control board when the STATUS LED on the machine control board underneath the dishwasher is STEADY OFF.

--->Here's the machine control board for your model you can order: WD21X24900

Let us know how it goes after you replace it.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,333
Location
McMullen Valley, Arizona
I am please to say I am up and running! I was way over thinking the process to change out these two parts! Great instructions! clean dishes!!!
Excellent Cindy, glad to hear the new UI(user interface) Board fixed it.(y)

Thanks for the update!

Jake
 

Robb S.

Premium Member
Joined
Oct 18, 2021
Messages
3
Location
Virginia
My dishwasher is working again, but there is a little quirk. Both times I've run it I pushed the start button and it waited a couple seconds and the start button went dark. Then I push it again and it starts. Any ideas what that's about? At the end of the day it's working, but just seems a little odd.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,333
Location
McMullen Valley, Arizona
My dishwasher is working again
That's great news Robb, I'm glad to hear the new machine control board fixed yours.(y)

but there is a little quirk. Both times I've run it I pushed the start button and it waited a couple seconds and the start button went dark. Then I push it again and it starts. Any ideas what that's about?
That does seem odd, Was the door open or closed when you pressed start?

Try it both ways and see if that makes a difference.

I know if the door is open there is a short amount of time if the door is not closed that it will go dark.:)

Jake
 

Robb S.

Premium Member
Joined
Oct 18, 2021
Messages
3
Location
Virginia
I think it was just the fact that it was already dark from not being used, so when I first push the START button, then everything lights up and I have to push the start button again to get it going. For some reason I don't remember it being that way prior, but maybe I'm just not remembering correctly. Anyway, I think it's all good. Thanks again!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,333
Location
McMullen Valley, Arizona
Ok Robb, sounds good.:)

Thanks for the update! Many folks don't update us and we love updates here.:)

Jake
 
Top