• Please note, some of the links on our site are affiliate links (Learn More)

GDF520PMJ2ES GE Dishwasher - No power to control panel

tincup2002

Premium Member
Joined
Sep 2, 2020
Messages
6
Location
Central Pennsylvania
Model Number
GDF520PMJ2ES
Brand
GE
Age
1-5 years
Hello,

I have a 4 year old GE dishwasher, model GDF520PMJ2ES. I'm having trouble with getting and keeping the power to the control panel. I initially started having this problem about 3 months ago, so I replaced the main circuit board, which seemed to fix the problem. Unfortunately, the issue has reappeared, although intermittently until today. I have checked the power supply (its direct wired to its own circuit breaker) with a meter and it is ok. I have tried rewiring the pigtail thinking that perhaps the connection was bad to no avail. I have also replaced the main circuit board in the dishwasher as noted above and checked all the connections to the circuit board. The LED on the board glows green when the power is turned on - although I'm 100% sure what that means. Through all of this, the control panel is still dead.
And and all help will be greatly appreciated.
Thank you for your time,
Mike
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
40,657
Location
Murray, Utah 84107, United States
Remove power from the machine for longer than 30 seconds and access the main control board.
GE control 2.jpg

Restore power to the machine and check the service LED on the board. Is it ON, OFF, or blinking a pattern?
D-GE control board status led.jpg
 

tincup2002

Premium Member
Joined
Sep 2, 2020
Messages
6
Location
Central Pennsylvania
The power has been off since 7:30 this morning. Just turned it back on and the LED is still glowing green.
 

Attachments

  • 15990760533404441944843423233066.jpg
    15990760533404441944843423233066.jpg
    351.7 KB · Views: 39

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
40,657
Location
Murray, Utah 84107, United States
To Enter Consumer Error Mode: With the dishwasher in Standby Mode (not running a cycle), press and hold the Cycle Select and Start buttons simultaneously for 5 seconds.
On entry into the Consumer Error Mode, the control reports the door status for 10 seconds.
• All LEDs are solidly illuminated, if the door is detected as closed.
•All LEDs are flashing if the door is detected as open
After the door check, the control will enter a mode to display any error codes that are currently detected by the control.
If any of the LEDs illuminate, it indicates a fault condition is present. These fault displays cannot be cleared manually; they will be automatically cleared by the control when the fault condition is no longer present. The Lock LED is always illuminated when in error code mode.
 

tincup2002

Premium Member
Joined
Sep 2, 2020
Messages
6
Location
Central Pennsylvania
Still no LEDs are illuminated on the control panel. Could it be that the user interface is bad or could it be the door latch not recognizing that the door is closed completely?
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
40,657
Location
Murray, Utah 84107, United States

tincup2002

Premium Member
Joined
Sep 2, 2020
Messages
6
Location
Central Pennsylvania
So...
Got the U.I. panel installed and I've got power to the controls. Audible "beeps" when the door is closed and when you press any of the buttons on the front with the exception of the start cycle button. It does beep, but the tone is much lower and the dishwasher will still not start. According to the jumper setting table, everything is correct. I'm pretty sure that I'm missing something simple, but at this point, I'm not sure what.
Thanks for all your help so far.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
115,886
Location
McMullen Valley, Arizona
Did you order the UI Board from Rick's post #8 to it above at AppliancePartsPros?

You're absolutely sure you set the personality jumpers properly per the instructions that came with it?

Jake
 
Top