• Please note, some of the links on our site are affiliate links (Learn More)

GDF570SSJ0SS GE Dishwasher - Intermittently Unresponsive

buzzard86

Premium Member
Joined
Sep 30, 2020
Messages
5
Location
PA
Model Number
GDF570SSJ0SS
Brand
GE
Age
1-5 years
Hoping you can help me troubleshoot and repair a GE dishwasher. I've researched and discovered that my issue seems to be common, but I found no reports of successful repairs.

GE GDF570SSJ0SS

The dishwasher will intermittently be unresponsive - no lights, buttons inop. Prior to yesterday, resetting the main circuit breaker several times would restore function. Now it's totally inop and the circuit breaker trick doesn't seem to work any longer.

Found multiple reports of the same symptoms and repair "trick". Main circuit board seemed suspect, but I also came across more than a handful of reviews that said the board did not fix the problem and had to be returned. A few speculated that the latch switch could be the culprit.

Any insight or advice on how to troubleshoot would be greatly appreciated.

Thanks.

Jim
 

buzzard86

Premium Member
Joined
Sep 30, 2020
Messages
5
Location
PA
Hi again! So I continued to search/research on here after posting this and I think I did find a successful repair to the same problem in a thread posted April 8th, 2020. In that thread, he tested an found 13.5v at the J722 connector and subsequently replaced the UI Board with a successful outcome. I plan to target and test the same.

I'm handy and ready to jump into this without reservation, but admittedly haven't taken anything apart yet and have no idea where I find the control board and this J722 connector. Is it fairly intuitive once I pull the panel beneath the door?

Thanks.

Jim
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,052
Location
McMullen Valley, Arizona
Hi Jim, Check the STATUS LED on the control board. Is it STEADY ON, STEADY OFF, or BLINKING a pattern? Check for 120 Volts AC at the control board connector.

GE control 3.jpg


D-GE control board status led.jpg


If it's STEADY ON=UI personality not set, communications lost between UI and MC.

For all models except GDF510J, the UI operational voltage is output from the main control board on connector J722 pin 2 Black/Green to pin 5 Yellow/Blue is 13.5 Volts DC.

Snapshot_2 (1).jpg


If 13.5 Volts DC is found and the UI(User Interface) does not function, replace the UI board.

--->Here's the UI board for your model you can order: WD21X23463 Kit Svc Ui Front Logic

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,052
Location
McMullen Valley, Arizona
Just take the voltage reading from the J722 connector on the back side of the control board.

That J722 connector is on the other side of the control board, look here:

J722.jpeg


It's the one on the left above the ethernet port.:)

Jake
 

buzzard86

Premium Member
Joined
Sep 30, 2020
Messages
5
Location
PA
Thanks, Jake! I'll take a look here in a bit and report back.

So the circuit breaker trick worked again so at present the dishwasher in functioning, although I know it's just a matter of time until it goes inop again. Should I wait until it's not working again to assess the STATUS LED and J722 voltage?

Jim
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,052
Location
McMullen Valley, Arizona
Yes Jim, wait till its not working then FIRST--->Check the STATUS LED on the control board. Is it STEADY ON, STEADY OFF, or BLINKING a pattern?

Jake
 

buzzard86

Premium Member
Joined
Sep 30, 2020
Messages
5
Location
PA
Hey Jake - I'm still here. Dishwasher has ironically been working since my post, so I'm waiting for it to freeze again so I can make the checks. Will update when able, just wanted to let you know that I didn't just post and disappear.

Thanks.
-Jim
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,052
Location
McMullen Valley, Arizona
Ok Jim, sounds good.

Jake
 

voidifopen

Premium Member
Joined
Oct 7, 2020
Messages
6
Location
PA
Hi Jake,

I have a similar problem as Jim and was hoping you can help.
My dishwasher (GDT655SSJ0SS) has no power (display and buttons not working) to the UI at all. I have tried replacing both the MC & UI and still have no power. When the UI is connected to the MC the LED is steady green. When disconnecting the UI from the MC the MC led blinks steady green. I put a voltage meter on the J722 (pin 2 & 5) the reading shows as 14.14 dc. I have tried turning off and on the breaker to reset the unit and it makes no difference.

Any Ideas?

Thanks,
Chris
 

voidifopen

Premium Member
Joined
Oct 7, 2020
Messages
6
Location
PA
One more thing, i have not reassembled the door and am testing with the inner door laying on the floor...not sure if there is some sort of safety that requires the dishwasher door to be reassembled?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,052
Location
McMullen Valley, Arizona
Hi Chris,

Did you set the personality jumpers before you installed the new UI Board? The instructions always come with the new UI Board and shows you how to set the jumpers.

--->If the personality is not set by using the 4 jumpers, the buttons, LED’s or cycles will not function properly.

Jake
 

voidifopen

Premium Member
Joined
Oct 7, 2020
Messages
6
Location
PA
Hey Jake,

No I did not! I am a typical guy when it comes to reading instructions...i'll give that a shot when i get home and update. Thanks for the quick reply, it is much appreciated!

Thanks,
Chris
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,052
Location
McMullen Valley, Arizona
Ok Chris, yes set the personality jumpers per your model number on the instructions and it should start working great.:)

Let us know how it goes.

Jake
 

voidifopen

Premium Member
Joined
Oct 7, 2020
Messages
6
Location
PA
Hi Jake,

That did work and the UI is lighting up correctly now, but i seem to be having an new issue that was not occurring previously. When hitting the start button, the start and front lights (maybe same as the lock control light) blink and the unit beeps 3 times every minute or so. Reading online a bit i came across some sites that mention the lock control mechanism may be the problem or that the screws that hold the dishwasher to the counter may be too tight pulling up the locking mechanism so it does not make peoper contact with the lock . I dont think the screws are too tight and it seems a bit strange the locking mechanism is now a problem (was not before, well i dont think it was), but maybe i damaged something when taking apart the door?

Any ideas on what is causing this new issue?

Thanks,
Chris
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,052
Location
McMullen Valley, Arizona
Ok Chris,

You mean the LOCK light is ON?

This is from your owners manual--->To UNLOCK the dishwasher control, depending on the model, press and hold the 1 or 2 buttons indicated on the controls for 3 seconds. The Control Lock light will turn off to indicate the control is unlocked.

Try that and keep us posted.

Jake
 

voidifopen

Premium Member
Joined
Oct 7, 2020
Messages
6
Location
PA
No, I don't think that is the issue. I can lock the dishwasher but then it won't respond when I select a cycle and hit the start button. Here are some pics so you can see the lights I am talking about.

When I set the cycle and hit start and for 2-3 seconds it appears it wants to start, but then the light above the start button (hidden buttons not on the front of the unit (see pic w/ door pulled out)) and the light on the front of the unit (see pic) start blinking and the dishwasher chirps 3 times every 60 seconds or so bit nothing happens after that. I have a feeling the problem is a faulty locking mechanism, but i am not 100% sure as that was not an issue before the UI bit the dust.
 

Attachments

  • dishwasher.JPG
    dishwasher.JPG
    66.3 KB · Views: 27
  • dishwasher2.JPG
    dishwasher2.JPG
    52.3 KB · Views: 25

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,052
Location
McMullen Valley, Arizona
Ok Chris, I see what you mean now.

Check the STATUS LED on the control board. Is it STEADY ON, STEADY OFF, or BLINKING a pattern?

Jake
 

voidifopen

Premium Member
Joined
Oct 7, 2020
Messages
6
Location
PA
Well this is strange. The light was blinking once every 3 seconds. I tried hitting start to see if the blinking pattern changed and the dishwasher started filling with water!?!

Besides removing the power wire cover and unscrewing the the screws holding the MC up, the only difference (that i am aware of) between starting this dishwasher this time vs last time is that last time there were a few dishes in the dishwasher and this time there were none.

Oh, and the light is now blinking 3 times in succession every 3 seconds now as the dishwasher is running. I am a bit worried that once i screw the MC back into place it may stop working again.

Are intermittent problems like this common for the GE's?

Do you by chance also own a similar GE?

Thanks,
Chris
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,052
Location
McMullen Valley, Arizona
Make sure all the connectors are tight on the main control board Chris.

Are intermittent problems like this common for the GE's?
No, not after the main control board has been replaced.

Do you by chance also own a similar GE?
Nope, I have a Maytag dishwasher I bought new in 2014 when I moved from Oregon to Arizona. Not a single problem with it since I've owned it.

Maytag and Whirlpool are the only products allowed in my house. LOL They have the best reliability.:)

Jake
 

buzzard86

Premium Member
Joined
Sep 30, 2020
Messages
5
Location
PA
Hi Jake -

I'm back. Dishwasher finally stopped working again. LED is solid green and I have 14.15v between pins 2 and 5.

Ordering the new UI board now.

Thanks.
Jim
 
Last edited:
Top