GDF610PSJ2SS Won't Start Wash Cycle

straylightrun

Premium Member
Joined
May 28, 2019
Messages
7
Location
Ohio
Model Number
GDF610PSJ
Brand
GE
Age
1-5 years
Recently my dishwasher started beeping randomly. However, it was still working. Two days ago, it stopped completely. All normal LEDs come on, but when I press Start, the LED stays solid for 5 seconds and then beeps a few times before doing nothing at all. I stay in another post to hold Select Cycle and Start and when I do that, all of the LEDs blink and an "815" shows in the LED display. I thought it may be something to do with the door, but I've tried several times to put pressure around the latch area, added tinfoil to see if that would give it more "contact," and cleaned out the areas around the latch with no effect.

Please help and thank you!!
 
Last edited by a moderator:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,082
Location
McMullen Valley, Arizona
Hi,

Your missing a digit between the "J" and the "S". Your model number tag is located inside the door on the tub frame.

Here's the results I get:
GDF620HSJ0SS
GDF620HSJ2SS
GDF620HSJ4SS
GDF620HSJ5SS
GDF620HSJ6SS

Jake
 

straylightrun

Premium Member
Joined
May 28, 2019
Messages
7
Location
Ohio
GDF610PSJ2SS

I'm not sure where I got that first model number. Should I delete this thread and start a new one with the correct number?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,082
Location
McMullen Valley, Arizona
Thanks, no need to start a new thread, I corrected it in your first post.:)

Your CSM maybe tripped.

To determine if the CSM is tripped, enter Consumer Error Mode.
Press the Select Cycle and Start buttons at the same time for Five (5) seconds. If the control responds with LED’s or Display coming on, The CSM is tripped.

To reset the CSM.
Entering Service Mode will reset the CSM.
To enter Service Mode:
1. First enter Consumer Error mode as directed previously. After the ten (10) second door check has completed, continue to next step.
2. Enter Service mode (while in Consumer Error Mode), by pressing and holding the Select Cycle button for five (5) seconds.

Let us know it that fixes it.

If that does not fix it:

Then look here at page 41: https://drive.google.com/open?id=1XTOXM0wA0UJEuucW0deIni17sMPtDGtD

See how many times your control board Service LED is flashing.

To view the Service LED, remove the lower access panel of your dishwasher.

--->Here's the main control board for your model: WD21X24798

Here's the video that shows you how to remove the cover to access the Service LED on it: Main control board access video

Jake
 

straylightrun

Premium Member
Joined
May 28, 2019
Messages
7
Location
Ohio
Per the first part of your post...

After holding down Start + Select Cycle, all LEDs blink and there is an 815 in the display. Once those stop, I held down Select Cycle for 5 seconds and the green LED beside “normal” lit up but nothing else happened. After two minutes or so it reverted to the normal display with my previous settings lighting up. Am I doing that correctly before moving on to the next step of accessing the control board?

Thank you!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,082
Location
McMullen Valley, Arizona
Look on Page 39.

To Enter Consumer Error Mode: With the dishwasher in Standby Mode (not running a cycle), press and hold the Cycle Select and Start buttons simultaneously for 5 seconds.

On entry into the Consumer Error Mode, the control reports the door status for 10 seconds.
• All LEDs are solidly illuminated, if the door is detected as closed.
• All LEDs are flashing if the door is detected as open.

See how many times your control board Service LED is flashing.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,082
Location
McMullen Valley, Arizona
That's odd, lets ignore that for now, the very important part I need to know is how many times your control board Service LED is flashing?

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,082
Location
McMullen Valley, Arizona
Ok, since the Service LED is OFF, then the problem is the control board.

Order the control board, --->Here's the main control board for your model: WD21X24798

Jake
 

straylightrun

Premium Member
Joined
May 28, 2019
Messages
7
Location
Ohio
Is this a newer version of the board for this dishwasher? When I looked up the parts it listed a different model number for the control board.

Thank you!!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,082
Location
McMullen Valley, Arizona
Yes, this is a updated newer version control board for your model.:)

Jake
 

straylightrun

Premium Member
Joined
May 28, 2019
Messages
7
Location
Ohio
Hello! I installed the new control board and I’m still getting the exact same symptoms. The control board has no LED flashing.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,082
Location
McMullen Valley, Arizona
Ok, then something is very strange.

You'll need to get GE to come out and see what's going on: 1-800-432-2737

We did what the tech data sheet said to do for no LED flashing.

Jake
 
Top