• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GDT645SYN0FS GE dishwasher starts cycle but doesn't complete. random H20 errors

acamato

Premium Member
Joined
Aug 9, 2010
Messages
4
Location
New York
Model Number
GDT645SYN0FS
Brand
GE
Age
1-5 years
Was getting random H20 errors. Had water pressure and flow. Would try to rerun a cycle and it would eventually compete the cycle.
now, when starting a cycle the drain pump will run, then the nothing else.
I ran the service mode tests and everything seems to be working (drain pump, water valve, circulation valve). The control board is blinking green.
I got a board from eBay (from a scratch and dent unit). It has the H20 error at first, then I cycled power it worked for a few cycles. Now its doing he same thing.

Should I get a new board?
 

acamato

Premium Member
Joined
Aug 9, 2010
Messages
4
Location
New York
Maybe solved. I took apart thr pressure switch and found it clogged. I cleaned it out and put it back in. The drain pump ran a second and the water valve opened. As I am trying this, the circulator pump just started.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,312
Location
Redmond, Oregon
Is it working good still now?

Yes, another member had this same issue:

Your model uses the same exact machine control board.

Here's the machine control board for your model:

Jake
 

acamato

Premium Member
Joined
Aug 9, 2010
Messages
4
Location
New York
It’s fixed. Ran two cycles with no issue. The original control board is in it. Now I have a spare board.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,312
Location
Redmond, Oregon
Ok, sounds good.(y)

Thanks for the update!

Jake
 
Top