FIXED GDT655SGJ0BB GE Dishwasher Not starting, beeps three times

MADuke78

Premium Member
Joined
Nov 8, 2019
Messages
4
Location
Rock Hill
Model Number
GDT655SGJ0BB
Brand
GE
Age
1-5 years
Howdy. We have had this dishwasher for almost 2 years. Normally when you hit start, the orange light on the front will light up and stay on until the cycle is finished. Recently, when I hit the start button, the light will not come on, but after about 3 seconds it will flash and beep three times. The first couple of times this happened, we just flipped the circuit breaker and it worked when it powered back up. Now it will not. We've changed the water inlet valve and the door latch and it is still doing it. We've checked the water tubing going in and going out to make sure that there isn't a clog. Nothing is working. Is there something else that it could be?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,680
Location
McMullen Valley, Arizona
Hi,

Here's the tech data sheet for your model: https://www.dropbox.com/s/ynaoqi9oboud0lo/31-30792 GE GDT655SGJ0BB Mini Manual.pdf?dl=0

--->Check your main control board Service LED, Tell us how many times its flashing in a row.

To view the main control board Service LED, remove the lower access panel of your dishwasher.

--->Here's the main control board for your model:

Here's the video that show you how to remove the cover to access the main control board, and Service LED on it: Main control board access video

Make sure you leave all the connections connected to the control board when viewing the Service LED.

Jake
 

MADuke78

Premium Member
Joined
Nov 8, 2019
Messages
4
Location
Rock Hill
Good morning. When I did the Select Cycle & Start test, all of the lights are flashing. Based on the service manual, I understand that means the door is not closed. 😕 I changed the door latch and the door is closed. Can the part that is attached to the door go bad as well?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,680
Location
McMullen Valley, Arizona
You bet it can, that's why you have to see how many times your SERVICE LED is flashing on the control board. Without that information we are dead in the water.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,680
Location
McMullen Valley, Arizona
You did leave all the electrical connections connected to the control board when you viewed the SERVICE LED? If so and no LED, then Yes, you nailed it, bad control board!

Order the control board I posted in link #2 and you should be back in business.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,680
Location
McMullen Valley, Arizona
Excellent, glad to hear the new control board fixed it. (y)

Thanks for the update!

Jake
 
Top