• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GDT655SMJ0ES GE Dishwasher Control panel lights not working and non-responsive/like no power

Status
Not open for further replies.

pete_plp

Premium Member
Joined
Nov 12, 2019
Messages
5
Location
Jeffersonville,IN
Model Number
GDT655SMJ0ES
Brand
GE
Age
1-5 years
I reviewed several threads (2 particularly helpful ones listed below) and found the following:

-I can reset the CSM but died 15-20 mins into the cycle. Can reset again and see 815 but it will keep failing

-Opened the MC and gets 1x per second blinking pattern (From service manual page 48 “Communications lost between control boards. Check connections, replace UI or MC as needed”)

-I checked UI operational voltage is output from the main control board on connector J722 pin 2 black/green to pin 5 yellow/black and got 14.01 multiple times.

The only thing I couldn’t check was the voltage on the IU like instructed on page 48 : “UI operational voltage is input at the UI control on connector J401 pin 1 black/green to pin 2 yellow/blue. If voltage is not found here, but was found in the previous step, check and replace the door
harness (if needed). If 13.5 VDC is found and the control does not function in consumer error mode, replace the UI”

So at that point I was getting ready to order WD21X23462 Kit Svc Ui Front Logic, thinking that’s what I needed but unfortunately it’s out of stock everywhere?

Left without a quick options, I wanted to ask

1-Does it sound like the IU?
2-Any idea why its out of stock and when it should come back?


Thank you in advance for your help


Helpful Previous Threads consulted


 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
41,160
Location
Murray, Utah 84107, United States
Do this; While the dishwasher is in standby mode press and hold the Cycle Select and Start pads simultaneously for 5 seconds. Upon entry into error mode the control reports the door status for 10 seconds. If the control senses the door is closed the LEDs will be solid. Open they will be blinking. After the 10 second door check the control will display any errors currently detected by turning on one of the LEDs. Which one is lit?
 

pete_plp

Premium Member
Joined
Nov 12, 2019
Messages
5
Location
Jeffersonville,IN
Hi,

Got into error mode, can see all LEDs solid and blinking if I open the door. After the 10 secs, Im left with only the Orange Led from lock controls (see attached picture)

from the manual it says “Error Code Display Mode is active” ? What does it mean?

The LED from MC was now blinking 7 times so went and reset the CSM and came back to 1 blink per second

thanks for your help
 

Attachments

  • 7CD33B2D-C8EE-430C-B9B2-EE0C5FE465F6.jpeg
    7CD33B2D-C8EE-430C-B9B2-EE0C5FE465F6.jpeg
    25.5 KB · Views: 103

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
41,160
Location
Murray, Utah 84107, United States
Orange Led from lock controls (see attached picture)
Start LED or lock LED? I can't see anything in the pic. Look closely around the circulation motor and drain motor for any signs of leaking
 

pete_plp

Premium Member
Joined
Nov 12, 2019
Messages
5
Location
Jeffersonville,IN
So it was only the “Lock LED” However since the CSM reset, I was able to do 2 full light wash les and 1 Normal wash without any issue. But now after a couple hours of not using it, it seems that the IU went dead again. I see no light on the MC and in error mode I get the LED lights autosense, lock and start. The CSM is not even resetting like if it wasn’t even tripped?
 

Attachments

  • 0A7C0179-95F1-4110-AB27-8B7196AEBFFB.jpeg
    0A7C0179-95F1-4110-AB27-8B7196AEBFFB.jpeg
    278.9 KB · Views: 164

pete_plp

Premium Member
Joined
Nov 12, 2019
Messages
5
Location
Jeffersonville,IN
was it the led light leading you towards that issue? I cannot find any sign of leakage or even humidity signs left from a dry spot? 😢
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,045
Location
McMullen Valley, Arizona
Rick is correct, 815 is a leak code. I had this happen at a customers house in my local area, its their winter house, when they leave for the summer and come back for the winter the first time they use their GE dishwasher it throws that 815 code, then all we do is reset the CSM, and they are good to go for the rest of the winter.

So I'd order and replace the main control board if you find no water leak.

--->Here's the main control board for your model: WD21X24901 Machine Control

Look here:

Let us know how it goes.

Jake
 
Status
Not open for further replies.
Top