• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GDT655SSJ0SS Dishwasher Won't Start - Beeps Three Times

R.J.

Premium Member
Joined
Feb 12, 2022
Messages
11
Location
VT
Model Number
GDT655SSJ0SS
Brand
GE
Age
1-5 years
Good afternoon,

My ~ 5 year old GE Dishwasher GDT655SSJ0SS stopped working this morning. I tried to start a cycle this morning and nothing happened. When I shut the dishwasher, the orange light flashes and I get three beeps every so often. I have unplugged the machine multiple times with no change. I held on the "Cycle Start" and "Start" buttons simultaneously and with the door open the LED lights flash and when I close the door the LED lights still flash. I accessed the main control board and found that the Status LED is NOT on at all. Since I have lights on my control panel I'm fairly certain that I'm getting 120 volts to the dishwasher. Do you suspect that I have a bad main control board?

Approximately six months ago I had to replace the UI board and now I'm wondering if it's worth it to replace the control board and just buy a new dishwasher.

I would appreciate any insight into what my issues are.

Thanks in advance,
--R.J.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
136,043
Location
Vicksburg Junction, Arizona
Yes, If you are getting 120 volts to the machine control board(under the dishwasher) and the STATUS LED is STEADY OFF, that means the machine control board is the culprit. Since you are getting lights and beeping that indicates you are getting 120 volts to the machine control board. So your machine control board is bad.

--->Here's the machine control board(under the dishwasher) for your model: WD21X24901 Machine Control

This video gives you the general idea of how to replace it:


Jake
 

R.J.

Premium Member
Joined
Feb 12, 2022
Messages
11
Location
VT
Hi Jake,

I got the control board today and installed it according to the video above and all went well with the install (certainly easier than the UI board). When I plugged my dishwasher back in, I'm not able to get the dishwasher to start. I press the start button and it makes an audible noise, but the button does not illuminate and the dishwasher does not start when closed. I held on the "Cycle Start" and "Start" buttons simultaneously and with the door open the LED lights flash and when I close the door the LED lights are now solid. This is good news because prior to replacing the control board the LED lights flashed with the door closed.

Any suggestions on how to get the dishwasher button to illuminate and start a load?

Thanks in advance.
 

R.J.

Premium Member
Joined
Feb 12, 2022
Messages
11
Location
VT
The status light on the control board is now flashing green.
 

R.J.

Premium Member
Joined
Feb 12, 2022
Messages
11
Location
VT
The LED light on the control board is now flashing 6 times in a row. What does that mean?
 

R.J.

Premium Member
Joined
Feb 12, 2022
Messages
11
Location
VT
@Jake - can you offer any suggestions on my situation? Replaced the main control board and the start button does not illuminate. I can press the start button and it makes an audible noise, but I can't get the dishwasher to start. I have shut off the power for up to 30 minutes several times and that hasn't seemed to help. The LED status light on the control board is flashing 6 times in a row. I tried to research the "flashing 6 times in a row", but didn't find any helpful information.
 

Yankeefix

Premium Member
Joined
Apr 16, 2022
Messages
12
Location
Charleston SC
@Jake - can you offer any suggestions on my situation? Replaced the main control board and the start button does not illuminate. I can press the start button and it makes an audible noise, but I can't get the dishwasher to start. I have shut off the power for up to 30 minutes several times and that hasn't seemed to help. The LED status light on the control board is flashing 6 times in a row. I tried to research the "flashing 6 times in a row", but didn't find any helpful information.
You may find a tech sheet attached to the lower toe panel that offers some detailed troubleshooting , I had this one on file, and hope it helps
 

Attachments

  • GE 6X.png
    GE 6X.png
    23 KB · Views: 114

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
136,043
Location
Vicksburg Junction, Arizona
Ok, 6x per 3 seconds--->Dishwasher is in Demo Mode.
To exit Demo Mode, press and hold Start and Heated Dry for 5 seconds.

Did you already do that? If so and it didn't work, then it seems like the new machine control board is defective. Contact the place you got it from and they should be able to send you another new one.

Jake
 

R.J.

Premium Member
Joined
Feb 12, 2022
Messages
11
Location
VT
Thanks Jake and Yankeefix. All I had to do was exit demo mode and I was able to get the dishwasher functioning again. I appreciate your help.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
136,043
Location
Vicksburg Junction, Arizona
Good job, glad to hear that.(y)

Thanks for the update!

Jake
 

Clamberth

Premium Member
Joined
Oct 22, 2022
Messages
2
Location
Los Angeles
GDT695SSJ0SS - @Jake Same flashing amber LED light on door with 3 beeps. Accessed the machine control board under unit to reveal 2x blinking light on the Green service LED.

What does this indicate and what are the next troubleshooting steps?

image.jpg
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
136,043
Location
Vicksburg Junction, Arizona
2x per 3 seconds - Unit is in delay start, so if you don't have it in delay start, then the problem is possibly the machine control board. I posted the link to it above in post #3.

Jake
 

Clamberth

Premium Member
Joined
Oct 22, 2022
Messages
2
Location
Los Angeles
Thanks Jake. I ended up doing 2 things. 1) left circuit breaker off for 30 minutes, then turned back on; 2) pushed the DELAY HOURS button through the cycle of options (1 to 12 hours) and then back to no delay.

After that, pushed START once, closed the door and the wash cycle began. (I reassembled the board pan, j-box and kick plate after the full cycle ended) Problem solved. Never had to replace the board.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
136,043
Location
Vicksburg Junction, Arizona
Sounds good.(y)

Thanks for the update!

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top