• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GDT695SMJ0ES GE Dishwasher: touchpad problems and not working

Status
Not open for further replies.

gastan

Premium Member
Joined
Oct 2, 2020
Messages
3
Location
Oregon, USA
Model Number
GDT695SMJ0ES
Brand
GE
Age
1-5 years
GE dishwasher model: GDT695SMJ0ES

After about 3-1/2 years with no problems the dishwasher started acting up. The touch pad would light up with no imput from anyone. (This was with the door closed but not latched, which is how we left it between uses.) One moment the touch pad would be dark (turned off) and the next it would be lit. The manual says to press the 'start' pad for until you hear a small beep (about 5-10 seconds) would cancel a cycle and that is what we did to get the lights to turn off. The problem got progressively worse - - happening more often - - over the next 4-5 months. One day the touch pad was dead. Dead. No response at all to any touches or prods. A hard reset (turning the breaker off/on) got it working again. Problem with the lights coming on by themselves continued and got worse. Hard reset the machine several times over 2-3 weeks. Finally even a hard reset did not work. Machine was dead. After googling I decided the main control board was bad so I ordered a new one and changed it out.

Machine started right up after restoring power after the main control board replacement - - - - but the touch pad light problem started up again that very same day. Now, after just one week and only using the dishwasher 2-3 times, the panel is dead again. The touch pad will not light up at all and the machine is useless. Hard reset did not work.

Any thoughts on what could be wrong? Sorry about the long post but am trying to be as complete as possible and anticipate any questions.
 

gastan

Premium Member
Joined
Oct 2, 2020
Messages
3
Location
Oregon, USA
After reading thru some posts and answers I went and checked the main board status light. It is on steady - - no flashing, just a steady green light.

Also, I see references to a UI board and a main board. Are they different boards or just two names for the same thing?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,951
Location
McMullen Valley, Arizona
Hi, Yes, the UI Board is the one where you press the buttons on the top of your door. The main control board at the very bottom.

If the STATUS LED on the main control board is SOLID GREEN(STEADY ON), then its likely a bad UI(User Interface) Board.

Here's the UI(user interface) Board for your model you can order: WD21X23462 Kit Svc Ui Top Logic

You can verify that will a multimeter. The UI operational voltage is output from the main control on connector J722 pin 2 black/green to pin 5 yellow/blue. If 13.5 Volts DC is NOT there, replace the main control.

If 13.5 Volts DC is there, replace the UI Board.:)

Snapshot_2 (1).jpg


That J722 connector is on the other side of the control board, look here:

J722.jpeg


It's the one on the left above the ethernet port.:)

Let us know what you find.

Jake
 

gastan

Premium Member
Joined
Oct 2, 2020
Messages
3
Location
Oregon, USA
Sorry for the delayed reply. Ordered the UI board but had to wait for FedEx to get it to me. They had it "in transit" in town for 3-1/2 days. In other words - - they lost it and had to find it. And I paid extra for quick delivery.

Installed it and the dishwasher lit right up. It is just about finished with the 1st test run and it is working fine and no leaks. Fingers crossed. I probably replaced the main control board needlessly - - should have asked here before just assuming stuff. Oh well. Hoping it runs for more than a week or two before something else happens.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,951
Location
McMullen Valley, Arizona
Excellent, glad to hear the new UI Board fixed it.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top