• Please note, some of the links on our site are affiliate links (Learn More)

GDT695SSJ0SS GE Dishwasher - Unit will no longer start cycle

Lozik

Premium Member
Joined
Oct 6, 2020
Messages
4
Location
Dallas
Model Number
GDT695SSJ0SS
Brand
GE
Age
1-5 years
As the title states, the unit will not start a new cycle. Whenever I press start, this unit beeps as if the door is open, even when it's latched (orange flashing light at front). I ran a door diagnostic per the advice I found in another thread; I did this by pressing and holding the start and cycle buttons simultaneously. All lights on the unit flashed, indicating the door was open, even though it was closed.

At this point I pulled out the main control board - there is NO LED activity whatsoever, even when pressing buttons on the top panel. Is this a sign of a dead control board, or is there something I need to do in order to prompt the light? Have I overlooked anything?

Thanks!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,958
Location
McMullen Valley, Arizona
Ok, did you make sure all the electrical connectors were still in place on the main control board underneath the front of the dishwasher when you viewed the STATUS LED?

If so, and the STATUS LED was STEADY OFF, that means the control board is the culprit--->Here's the main control board for your model you can order: WD21X24901 Machine Control

Let us know how it goes.

Jake
 

Attachments

  • D-GE control board status led.jpg
    D-GE control board status led.jpg
    25.1 KB · Views: 26

Lozik

Premium Member
Joined
Oct 6, 2020
Messages
4
Location
Dallas
Wires are all connected. Power is on the top panel, but LED light is OFF on main control board. I even tried doing the consumer test mode (Page 40 of this doc), that lets you run the drain, heat element, etc - nothing is working, if that's also an indication of the main control board.

Before I order the part - Is there a place on the board to check continuity using a voltage meter before I order the part, or is this usually the issue?

Thanks
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,958
Location
McMullen Valley, Arizona
The main control board is ALWAYS the problem when the STATUS LED is STEADY OFF.

There is no other testing you can do.

Jake
 

Lozik

Premium Member
Joined
Oct 6, 2020
Messages
4
Location
Dallas
I ordered the part you recommended. I'll updated once I have it in. Thank you, Jake!
 

Lozik

Premium Member
Joined
Oct 6, 2020
Messages
4
Location
Dallas
So I disconnected and reconnected all the wires to the main control board, in a last ditch effort to fix, and the dishwasher now operates. It looks like the wire nuts were poorly attached. Seems to be shoddy wiring, but I would think that would affect the top panel (mine was still functioning), if the unit was not getting sufficient power. It works, but I'll be keeping an eye on it.

Thanks
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,958
Location
McMullen Valley, Arizona
Ok, yes shabby wiring and the wire nuts not tight can cause intermittent problems like this.

Yes, Keep your eye on it.:)

Jake
 
Top