• Please note, some of the links on our site are affiliate links (Learn More)

GDT695SSJ2SS GE Dishwasher totally dead

davidmichaelgil

Premium Member
Joined
Mar 26, 2020
Messages
7
Location
New York
Model Number
GDT695SSJ2SS
Brand
GE
Age
1-5 years
Came home and no lights, no response, nothing. Flipped the breakers, unplugged and tested power (socket worked fine with another device), tried lock-control reset, even pulled it out to see if anything up in back ...nothing visibly off. It's as though it's not plugged in, just completely dead. This machine is less than 2 years old and worked perfectly before. Please help,
thanks
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,969
Location
McMullen Valley, Arizona
--->Check your main control board STATUS LED, Tell us how many times its flashing in a row.

GE control 2 (1).jpg


--->Here's the main control board for your model: WD21X24901 Machine Control

D-GE control board status led.jpg


Make sure the door harness connector is attached to the bottom of the control board casing connector when you view the STATUS LED light, because if it's not that Service LED made be STEADY ON, which would be a false error code. Also make sure the 120 volt connector to it in the front is still attached to it also.

IF it the STATUS LED is STEADY OFF, then use a multimeter and check for 120 volts at the connector that says 120 volts that connects to the control board.:)

Let us know what you find.

Jake
 

davidmichaelgil

Premium Member
Joined
Mar 26, 2020
Messages
7
Location
New York
ok got the faceplate off, but not sure how to get the next part off. I dont see any screws?
can you clarify on this picture? thanks again

1585248844125.png
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,969
Location
McMullen Valley, Arizona
See the two screws with the rubber grommets? You remove those two screws. Then remove the J-Box, which is that metal box on the right side there.

Here's the video that shows you how, and then view the STATUS LED on it: STATUS LED Control Board Video

Yes, unplug the dishwasher first, then plug it back in once you have the control board in view. Don't remove the control board from its metal casing.:)

Jake
 

davidmichaelgil

Premium Member
Joined
Mar 26, 2020
Messages
7
Location
New York
Hi thanks again. I managed to get the control panel dropped down but I’m not exactly sure what I’m looking at, in any case I don’t see any LED lights at all. So do I need to go buy a multimeter? Assuming at Home Depot, Is that the next stop? Can you give me a general sense of what you think the issue might be? Thanks again for all the help
 

Attachments

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,969
Location
McMullen Valley, Arizona
Take a wider photo of the control board. Remember turn the power back on to your dishwasher as well when looking at it.

Yes, you will need a multimeter.

This is the one I use:
Yes, you can get one just like it at Home Depot.

Jake
 

davidmichaelgil

Premium Member
Joined
Mar 26, 2020
Messages
7
Location
New York
ok, got one from Home Depot, kinda cheap, but will see if i can sort it...
so i should plug the DW back in ?
then im looking for 120 volts at that bottom right position you indicated in the graphic above?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,969
Location
McMullen Valley, Arizona
so i should plug the DW back in ?
then im looking for 120 volts at that bottom right position you indicated in the graphic above?
Yes, exactly.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,969
Location
McMullen Valley, Arizona
Ok David, sounds good.

Jake
 

davidmichaelgil

Premium Member
Joined
Mar 26, 2020
Messages
7
Location
New York
Jake, an update. So, the guy came out and fixed it -- not sure what he did, but it was a quick fix. He didnt charge me, which was nice, but he said it will die again in a month, so buy the extended warranty. I guess its something with one of the 2 CPUs (Chinese boards, he was critical) in the machine. Well, anyway, I shelled out for 3 more years of an extended warranty with Assurant (wasnt cheap), and lo and behold, here we are a month later and its dead again. So i look up Assurant and the contract doesnt START until 6/5! So i have to wait until late next week to even start the process, which probably involves ordering a new board, right? AaAarg, what a piece of junk. GE, so unimpressive. Any other thoughts or advice? PS, do you have paypal or something? would like to give something nominal for your time... thx
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,969
Location
McMullen Valley, Arizona
lo and behold, here we are a month later and its dead again. So i look up Assurant and the contract doesnt START until 6/5! So i have to wait until late next week to even start the process, which probably involves ordering a new board, right?
Yes David, most likely the main control board is bad. But I would need to see the STATUS LED on the main control board to tell you.

PS, do you have paypal or something? would like to give something nominal for your time... thx
Yes, if you scroll down to the bottom of this page you will see a GOLD DONATE button.:)

Thanks!

Jake
 
Top