GDT695SSJ2SS GE Dishwasher won't start

tonster

Premium Member
Joined
Aug 18, 2019
Messages
3
Location
Ypsilanti, MI.
Model Number
GDT695SSJ2SS
Brand
GE
Age
1-5 years
I've got a GE GDT695SSJ0SS that is about 18 months old now. Yesterday I went down and found that the lights were all out and it wasn't responding. Also the last load that I had started the night before had apparently not been completed. There was no water inside the unit at all at the time. I unplugged it for a few minutes and plugged it back in and it functioned, but wouldn't start.

Reading through the forums it appeared it had somehow gotten stuck in demo mode and after replacing the door latch (which I now believe was likely working fine) and messing with it for an hour or so, it finally seemed to exit demo mode and I was able to run a load. It completed last night, and I noticed that the finished light did not come on and the dishes did not seem warm/hot as if the heat mode never activated. The dishes, while still fairly wet, all seemed to be clean however. After re-loading it, I was once again unable to start the dishwasher.

It now appears that it again feels that the door latch is malfunctioning, as it just blinks continuously and beeps every so often as if the door is not closed properly. I've gone through the service mode and attempted to activate each test, however in the 10 seconds of test when entering the mode and it seems to indicate the door is open. No modes will activate in service mode. At this point my thought is that it's the UI Board at the top of the door. When the panel stops working and I unplug it and plug it back in it sounds distorted when it finally turns on, and continues to occasionally sound that way when attempting to make it run. Does that sound like a good place to start or are there other troubleshooting steps I've missed?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
101,457
Location
McMullen Valley, Arizona
Hi,

Here's the tech data sheet: https://www.dropbox.com/s/ynaoqi9oboud0lo/31-30792 GE GDT655SGJ0BB Mini Manual.pdf?dl=0

--->The first 10 seconds is a door status check.
If the door is closed all the LED's will be solid.<---Did you close the door to make sure the LED'S were solid?
If the door is open all the LED's will flash.

--->Check your main control board Service LED, Tell us how many times its flashing in a row.

To view the main control board Service LED, remove the lower access panel of your dishwasher.

--->Here's the main control board for your model: WD21X24799 Machine Control

Here's the video that show you how to remove the cover to access the main control board, and Service LED on it: Main control board access video

Jake
 

tonster

Premium Member
Joined
Aug 18, 2019
Messages
3
Location
Ypsilanti, MI.
Well, I went to start removing the bottom panel and heard the unit start to drain as soon as I started to remove the second screw! I'm not sure if that indicates that there is some sort of short that the screw is touching a wire or just coincidence at this point, but since it started working i left it in that state to complete it's cycle for now. I'll check on it again in the morning and see how it looks and proceed to look at it in more detail when it's empty. Thanks for the advice, and nice to see the videos from repairclinic.com. They're about 10 minutes from my house and are great guys!

Tony
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
101,457
Location
McMullen Valley, Arizona
Ok Tony, sounds good, let us know if it acts up again.

You might want to check to make sure all your electrical connectors to the control board are on tight too.

Jake
 
Last edited:

tonster

Premium Member
Joined
Aug 18, 2019
Messages
3
Location
Ypsilanti, MI.
Okay, so it started acting up again yesterday and so far I haven't been able to make it work again. I took it apart tonight and got at the main control board. It blinks once every 3 seconds or so, which from the service manual appears to indicate that it's not running but ready to wash. If I push start, after a couple seconds it beeps 3 times and just blinks and it just repeats this every 30 seconds or so forever (or until I cancel the cycle). Entering Diagnostic Mode, it shows 817 on the LCD and then blinks when the door is open, and the status indicator is solid when the door is closed, so I think that the door latch, and with the old latch it was always blinking, so I think that was bad). No other codes are displayed. When entering Service Mode, everything seems to run at the proper time. I can hear the various components begin to operate and I see the tub fill and empty. Does this sound like a potentially bad UI Board, or something else?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
101,457
Location
McMullen Valley, Arizona
Ok, the problem is the main control board.

--->Here's the main control board for your model you can order: WD21X24799 Machine Control

Jake
 
Top