• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GE adora dishwasher DDT595SGJ5BB unresponsive

JasonTman

Premium Member
Joined
Oct 11, 2022
Messages
6
Location
Harvest
Model Number
DDT595SGJ5BB
Brand
GE
Age
1-5 years
GE dishwasher model: DDT595SGJ5BB
The control panel has no lights and is unresponsive.
This happened in the past, and I cycled the power, and it worked for a few months. I cycled the power a week ago, and it worked for another cycle. Now nothing is brining it back.
The control board has the blinking green light when power is applied. What are my next steps?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
137,406
Location
Vicksburg Junction, Arizona
Hi Jason,

The newer square control board(underneath the dishwasher) on your model has a steady flash pattern on the service LED and only indicates the dishwasher has power and DC voltage is being produced by the control board to send power to UI Board at top of the dishwasher door.

Unfortunately, there isn't a way to verify the DC volts to the UI Board on these newer square control boards.

You can check your door wire harness first to see if its shorting out, look for bad spots on it, look for any metal pins that have backed out of either side of the connectors that connect to the machine control board and UI Board.

To access the door wire harness--->You will need to remove the whole door, then separate the door.

Here's the service manual for your model: https://drive.google.com/open?id=1M-G9W3HiaYnihdB5Cy-jfSPoVf8DZ7j7

Page 28 Door Removal
Page 30 Separate Door

Here's the door wire harness for your model:

Here's the newer square control board for your model:

Here's the user interface(UI) Board for your model:
WD21X23461 Kit Svc Ui Top Logic


If you replace the UI Board--->Remember--->You have to set the personality jumpers on the new UI Board before you install it or it will not work, the instructions that come with the new UI Board shows you how to do it.

Jake
 

JasonTman

Premium Member
Joined
Oct 11, 2022
Messages
6
Location
Harvest
Jake, thank you for your reply!
Yes sir. The wiring harness did appear to have damage on a wire going to/from the detergent dispenser. Solid potential for a short there. (All the pins on both sides look/feel good.) Would that potential short crash the UI board?
With a meter I’ve checked voltage coming to the UI board, and voltage on each button as well as changes in voltage across the buttons when pressed.
I was ready to buy a new UI board until I noticed all the buttons seem to be electronically operational.
Even still, There is continuity through the cable [that may have been shorted], so sounds like the UI board may be the only possible issue left. (Of course I would want to repair that cable so it doesn’t fry another board… if that’s what happened.
Also, I’ve seen other videos about the personality jumpers, but I don’t see those present on this board. Is it possible this version doesn’t have those?
Thanks for your time! And the helpful resources! :)
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
137,406
Location
Vicksburg Junction, Arizona
Would that potential short crash the UI board?
Quite possibly yes.

Also, I’ve seen other videos about the personality jumpers, but I don’t see those present on this board. Is it possible this version doesn’t have those?
This UI Board does have the personality jumpers, look here:

Then look on the 2nd page:

Jake
 

JasonTman

Premium Member
Joined
Oct 11, 2022
Messages
6
Location
Harvest
It doesn’t look like there has ever been anything in these holes. But ordering a new board would have what I need, right? And walk me through the set up.
 

Attachments

  • A869B8AE-048A-4960-AEA1-76CD7374BCAB.jpeg
    A869B8AE-048A-4960-AEA1-76CD7374BCAB.jpeg
    423.2 KB · Views: 39

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
137,406
Location
Vicksburg Junction, Arizona
The original UI Board that came with the machine new does not have personality jumpers, only the replacement will.:)

There are videos on Youtube that show you how to set the jumpers and replace the UI Board.

Here's a good one:


Jake
 

JasonTman

Premium Member
Joined
Oct 11, 2022
Messages
6
Location
Harvest
Excellent! Thank you Jake. That answers my final question.
I hope you are doing well! I know this forum really appreciates all your input!!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
137,406
Location
Vicksburg Junction, Arizona
Thanks Jason.:)

Let us know how it goes.

Jake
 

JasonTman

Premium Member
Joined
Oct 11, 2022
Messages
6
Location
Harvest
Errrrr. I installed the UI board, and now the UI has some lights, and beeps and responds… kinda (the buttons don’t do what they say they’d do, And doesn’t do anything to the dishwasher components). I checked the personality pins. But they look right to me… thoughts? :/
 

Attachments

  • 35096497-8494-422F-BDCB-244A99E9EC4D.jpeg
    35096497-8494-422F-BDCB-244A99E9EC4D.jpeg
    114 KB · Views: 40
  • 48848F5F-47A2-452C-93F1-57961AF089BE.jpeg
    48848F5F-47A2-452C-93F1-57961AF089BE.jpeg
    384.1 KB · Views: 36
  • 843CD341-A16A-4D30-BA40-146DFB05B194.jpeg
    843CD341-A16A-4D30-BA40-146DFB05B194.jpeg
    239.9 KB · Views: 40

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
137,406
Location
Vicksburg Junction, Arizona
Ok, you have the personality jumpers set properly, so that indicates your UI Board came defective. Contact the place you got it from and let them know, and they should be able to send another new one.

Jake
 

JasonTman

Premium Member
Joined
Oct 11, 2022
Messages
6
Location
Harvest
Jake, thanks for this recommendation! By this time, I was out of Confidence, and unsure which direction to turn.
I reached out and let them know what was happening once I installed the new board, and they shipped a new one. Once installed, everything Worked perfectly! Thanks for all your help!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
137,406
Location
Vicksburg Junction, Arizona
Excellent Jason, glad to hear that.(y)

Thanks for the update!

Jake
 

bbradb

Premium Member
Joined
Nov 17, 2022
Messages
5
Location
SC
Jake,
Been following this thread for my DW. I have service manual you noted. No hint of issues however couple days ago no response from DW. No lights or beeps etc. All power to DW good. Dropped Main Control Board. I have new square board. Applied power and see rapid continuous blinking of Service Led on MC. I am not able to go into Consumer Error Mode or Service Mode. Page 45 in manual says: "Flashing rapidly - replace MC". Have not removed door and hope not to need. I have top of door UI. I will look over cable as best I can but is this indication my CB definitely needs replacing? Thanks in advance.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
137,406
Location
Vicksburg Junction, Arizona
Do you have the exact same model number DDT595SGJ5BB ? The model number tag is located inside the door on the tub frame.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
137,406
Location
Vicksburg Junction, Arizona
Thanks Bruce! I will help you in your thread you already made here:
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top