• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GE Dishwasher GDF520PSJ2SS - Control Panel not working

Status
Not open for further replies.

mark.a.murphy

Premium Member
Joined
Apr 10, 2022
Messages
10
Location
Woodbridge, VA
Model Number
GDF520PSJ2SS
Brand
GE
Age
1-5 years
I currently have no lights on the control panel. Over the past year this happened twice but cycling the breaker a few times resolved the issue. This time, breaker cycling is not correcting the issue. I checked the breaker and it is closed.

I opened the cover to the power line and verified 120V in. I tried manually closing the door shut switch (inserted a screwdriver) but no change. I removed the door shut switch and tested operation, seeing a change in resistance when the switch was shut (door closed). I exposed the control panel and the STATUS LED is ON solid. What should I check next? Thanks.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
If the machine control board STATUS LED is STEADY ON--->That usually indicates the UI Board is the culprit. To verify that you can follow the steps below.

Here's the UI(user interface) Board you would need: WD21X23463 Kit Svc Ui Front Logic

The UI operational voltage is output from the machine control board on connector J722 pin 2 black/green to pin 5 yellow/blue. If 13.5 Volts DC is found here, then the UI Board is the problem.

Snapshot_2 (1).jpg


Connector J722 is located on the metal casing side of the main control board.

J722.jpeg


It's the one on the left above the ethernet port.:)

"NOTE--->When replacing UI control boards, the new UI Board MUST be configured as per the instructions included with the replacement. If the personality is not set by using the 4 jumpers, the buttons, LED’s or cycles will not function properly".

Let us know how it goes.

Jake
 

mark.a.murphy

Premium Member
Joined
Apr 10, 2022
Messages
10
Location
Woodbridge, VA
Jake

Thanks! I did not recognize that you had responded (I'm not experienced with blogs)

I will order the UI card and replace it observing your cautions concerning personality jumpers in this thread:

PS I ordered a new control board before seeing your response but fortunately it is returnable.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
Ok, let us know how it goes.

Jake
 

mark.a.murphy

Premium Member
Joined
Apr 10, 2022
Messages
10
Location
Woodbridge, VA
Jake

Replaced the UI board - I now have lights on the display panel.
When I try to start, I get the 3 two-toned beeps and the start button light flashes
I tried opening the breaker for >1 minute (a couple times)
I turned the dishwasher off and on by holding the start button (a few times)
I tried resetting by holding down the start and wash temp buttons - heard decreasing freq tones (a couple times)
Checked the flashing LED on the control board - flashing twice every 3 seconds
I have not rechecked the latch switch or the voltage to the UI board (those were previously checked but I could recheck them)
Any suggestions on what to try next?

PS - I still have a new control board on hand, I have not yet returned it.

Mark
 
Last edited:

mark.a.murphy

Premium Member
Joined
Apr 10, 2022
Messages
10
Location
Woodbridge, VA
Correction - the LED light on the control board blinks:
-Once every 3 seconds when the Start light is off - no beeping
-Twice every 3 seconds when the Start light is on - accompanied by 3 two toned beeps
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
"NOTE--->When replacing UI control boards, the new UI Board MUST be configured as per the instructions included with the replacement. If the personality is not set by using the 4 jumpers, the buttons, LED’s or cycles will not function properly".

Did you set the personality jumpers on the NEW UI Board before you installed it? If not, that's the reason its not working right.

It should of come with the jumpers and the instruction sheet to show you how to set the jumpers.

See the instruction sheet and jumpers in this photo:
dishwasher 05.jpg
 

mark.a.murphy

Premium Member
Joined
Apr 10, 2022
Messages
10
Location
Woodbridge, VA
I should have mentioned. For my model (GDF520), the instructions showed a solid rectangle over all pins (pair for 8, 4, 2, and 1). I interpreted that as all 4 jumpers in place fully covering all the pins. Personality 15. Board arrived with all 4 jumpers in these positions.
 

Attachments

  • Jumper Settings-GDF520.jpg
    Jumper Settings-GDF520.jpg
    18.5 KB · Views: 41
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
Ok, good on the jumpers.:)

Ok, here's the service manual: https://drive.google.com/file/d/1XTOXM0wA0UJEuucW0deIni17sMPtDGtD/view?usp=sharing

Look on page 41 for:
-Once every 3 seconds when the Start light is off - no beeping
-Twice every 3 seconds when the Start light is on - accompanied by 3 two toned beeps

So its either the door latch switch or the machine control board underneath the dishwasher.

Here's the door latch switch for your model:
WD21X10490 Latch Switch


To Verify the door latch switch is good--->Follow the directions here:
LatchSwitch.png


Door closed: 0 ohms.
Door open: infinite ohms.

Let us know what you find. Make sure you disconnect power to the dishwasher before ohm testing.

If the latch switch is good, then it can only be the machine control board that's bad.

Jake
 

mark.a.murphy

Premium Member
Joined
Apr 10, 2022
Messages
10
Location
Woodbridge, VA
The saga continues.

I was unable to check the continuity on J711 because the probes on my multimeter are too large to fit into the pin openings on the connector. I tried using small pieces of wire stuck into the connector holes but I either did not make contact or there was no connectivity on either test.

So ... I ordered and replaced the door switch. I'm assuming that there is no reason to figure out the continuity readings but correct me if you disagree (perhaps there is a problem with the wiring harness that connects to the switch).

I'm still at the point where I hold down the Start button, the Start LED illuminates, and after a few seconds I get three sets of low-high beeps which repeat themselves every couple minutes.

At this point I have replaced the Machine Control Board, the UI board, and the door close switch. I will try going through the indicators one more time and read the user manual more carefully.

If that does not yield results I plan on giving up, buying a new dishwasher, and seeing what parts I can return.

If you have any better ideas I'm all ears.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
That's very odd.

Check the machine control board STATUS LED again(its located underneath the front on the dishwasher). Tell us how many times its flashing in a row, or if its STEADY ON or STEADY OFF.

Here's the machine control board(under the dishwasher) for your model: WD21X24900C

To view the STATUS LED, remove the lower access panel of your dishwasher. You DO NOT have remove the control board from its metal casing when you view the STATUS LED.

GE control 3.jpg


When you have that panel lowered down turn the breaker back ON to your dishwasher. When viewing it leave all the electrical connectors to it plugged in.

D-GE control board status led.jpg


Jake
 

mark.a.murphy

Premium Member
Joined
Apr 10, 2022
Messages
10
Location
Woodbridge, VA
LED light on the machine control board blinks:
-Once every 3 seconds when the Start light is off - no beeping
-Twice every 3 seconds when the Start light is on/blinking - accompanied by 3 two toned beeps
 

mark.a.murphy

Premium Member
Joined
Apr 10, 2022
Messages
10
Location
Woodbridge, VA
Jake

FYI - I also tried putting the unit into Consumer Error Mode. After the 5-10 seconds of all LEDs flashing (door was closed) the only LED that was lit was the "Locked" LED indicating that the Error Code Display mode is active. I did not see any other errors. I exited Consumer Error Mode.
 

mark.a.murphy

Premium Member
Joined
Apr 10, 2022
Messages
10
Location
Woodbridge, VA
Jake

I found video discussing the same symptoms that I'm seeing. Since I saw flashing LEDs in the first 5-10 seconds of being in the Consumer Error Mode, this indicates that the control board thinks the door is open (which it is not). In the video, they say that the problem is that the door switch is indicating open and they replace the switch (which I've already done). I'll disconnect and reconnect the door switch to the machine control board (both ends) but I'm wondering if one of the connectors or the wiring connecting the two could be bad.
 
Last edited:

mark.a.murphy

Premium Member
Joined
Apr 10, 2022
Messages
10
Location
Woodbridge, VA
Jake

The saga has ended .... dishwasher working

As best I can tell, it had multiple faults.

The reason that the new switch did not originally correct the door latch problem is that when I put the switch in it was not flush with the frame. Apparently, it was crooked enough to prevent a proper closed signal. That has been corrected.

That being said, I don't believe that the door switch could have been responsible for the original symptom of no LED lights. I'm not sure if all 3 major components (machine control board, UI board, and door switch) were bad but I believe at least 2 of the 3 failed. Seems odd that multiple components would fail simultaneously. My leading theory is that it was an electrical surge from storms while we were out of town but I have not seen any problems on any other electronics.

Thanks for all your help,
Mark
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
Excellent Mark, glad to hear your back in business.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
If you feel that you have benefited from this site, and would like to show your appreciation.
Top