• Please note, some of the links on our site are affiliate links (Learn More)

GE Dishwasher GDF570SGJ0CC - Suggestions for "won't start problem" were great! Still slightly puzzled

3rdQ

Premium Member
Joined
Sep 13, 2021
Messages
2
Location
USA
Model Number
GDF570SGJ0CC
Brand
GE
Age
1-5 years
Between reading through the forum archives (a big thank you👍) and the GE service manual it appears I solved my "won't start" problem.... but I can't quite put my finger on which step brought my dishwasher back to life. Since most posts are the "Help, my appliance is broken" kind of posts I thought I'd change up the format a little.

My initial problem was a blinking Start Button, and the dishwasher would not start a cycle. In the Consumer Error Mode, it failed the open and closed Door Latch Test. I replaced the upper control board, skipped any diagnostic tests, pressed the Start Button and it worked. After 3 or 4 loads of dishes, the dishwasher reverted back to the original symptoms of a blinking Start Button and it would not start.

Next, I replaced the UI board. Now when in Consumer Error Mode.... the Door Latch Test was successful in both the door-open and door-closed positions, and after the 10-second door test, I got no blinking LED's on any buttons. I had assumed I had reset the CSM if it was tripped. Going into Service Mode it did not sound like the Drain Pump Test (1-blink) did anything, but I could cycle through the other 4 tests. But the dishwasher still wouldn't start. I repeated the Consumer Error Code tests and the Service Mode tests with no help. I was ready to drop the bottom panel and do the LED Test on the UI board, but decided to double check that the dishwasher was not Demo Mode, and try another start.

Next, I pressed Start and it made a draining sound for 30 or 40 seconds. Could this be the missing (1-blink) Drain Pump Test I never could hear? After that ended I opened and closed the door, and pressed Start. Now the dishwasher went into a full cycle. It has run one more full cycle (in Light mode with Heated Dry). It appears to be fixed.

I'm curious if my testing and results sound normal, or does something sound out of whack? The testing in the manual sounds straight forward, but it looks like I solved my problem in a round-about way. Thanks for any comments.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,689
Location
McMullen Valley, Arizona
Next, I pressed Start and it made a draining sound for 30 or 40 seconds. Could this be the missing (1-blink) Drain Pump Test I never could hear?
Yes. So now lets see if it runs fine when use do your next dishwashing load or not.

The first place I always start is the machine control board, located underneath the dishwasher.

Check the machine control board STATUS LED first(its located underneath the front on the dishwasher). Tell us how many times its flashing in a row, or if its STEADY ON or STEADY OFF.

--->Here's the machine control board for your model: WD21X24901 Machine Control

To view the STATUS LED, remove the lower access panel of your dishwasher. You DO NOT have remove the control board from its metal casing when you view the STATUS LED.

GE control 2 (1).jpg


When you have that panel lowered down turn the breaker back ON to your dishwasher. When viewing it leave all the electrical connectors to it plugged in.

D-GE control board status led.jpg


Jake
 

3rdQ

Premium Member
Joined
Sep 13, 2021
Messages
2
Location
USA
Jake, like I said the dishwasher went into a full cycle and it ran just fine. After that I ran one more full cycle (in Light mode with Heated Dry). It appears to be fixed, so I'm keeping my fingers crossed.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,689
Location
McMullen Valley, Arizona
It appears to be fixed, so I'm keeping my fingers crossed.
That's what I meant, keep running more loads and see if it keeps running perfect.:)

Jake
 
Top