• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GE Dishwasher GDF570SGJ0WW dead, not working.

RonS.

Premium Member
Joined
Sep 25, 2022
Messages
4
Location
SC
Model Number
GDF570SGJ0WW
Brand
GE
Age
6-10 years
Hi everyone,

First-time poster, long-time lurker. Recently my GE Dishwasher GDF570SGJ0WW has stopped working altogether. Loaded it up to run a load and pushed the button and got no lights, sound, or any response from pressing the buttons. I flipped the C/B off for a few minutes and when I turned it back on I still have nothing.

I checked and the unit is getting power and the green light on the board under the unit is steady on, not flashing. I did check for continuity on the door switch and all the buttons on the display circuit board and they seem to be working. Does anyone have any suggestions?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,144
Location
Redmond, Oregon
Hi Ron! If the machine control board(underneath the dishwasher) STATUS LED is STEADY ON that usually indicates a bad UI Board.

To verify that--->You will need a multimeter to check for 13.5 Volts DC.

The UI operational voltage is output from the main control board on connector J722 pin 2 black/green to pin 5 yellow/blue. If 13.5 Volts DC is found here, then the UI Board is the problem.

Here's the UI(user interface) Board for your model:

When you click the UI Board part link you will see a video of how to replace it.

"NOTE--->When replacing UI control boards, the new UI Board MUST be configured as per the instructions included with the replacement. If the personality is not set by using the 4 jumpers, the buttons, LED’s or cycles will not function properly".

Snapshot_2 (1).jpg


Connector J722 is located on the metal casing side of the main control board.

J722.jpeg


It's the one on the left above the ethernet port.:)

Let us know how it goes.

Jake
 

RonS.

Premium Member
Joined
Sep 25, 2022
Messages
4
Location
SC
Thank you Jake,

I am getting 14.12 VDC from the control board and checked the wiring harness to the UI for continuity and everything is checking out well. So it looks like my UI board then,
 

RonS.

Premium Member
Joined
Sep 25, 2022
Messages
4
Location
SC
I will follow up once my part arrives and I get it installed. Thanks again Jake for your response.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,144
Location
Redmond, Oregon
Yes, you are correct, the UI Board is the culprit.

I will follow up once my part arrives and I get it installed.
Yes, thanks! We love updates here.:)

Jake
 

RonS.

Premium Member
Joined
Sep 25, 2022
Messages
4
Location
SC
Hello everyone,

I just wanted to follow up on my UI board change results. Even though there appeared to be nothing wrong with my original board externally, the dishwasher came to life once I changed the UI board out and has worked great. I have run a few loads through it getting caught up and it appears to be working as it should.

Thanks again Jake for the pictures and the assistance, I appreciate all your help.

Thanks,
Ron
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,144
Location
Redmond, Oregon
Excellent Ron, glad to hear the new UI Board fixed it.(y)

Thanks for the update!

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top