• Please note, some of the links on our site are affiliate links (Learn More)

GE Dishwasher GDF630PGM0BB No Power on UI

thestanger

Premium Member
Joined
Aug 16, 2022
Messages
3
Location
nj
Model Number
GDF630PGM0BB
Brand
GE
Age
1-5 years
So about 6 months ago my machine just shut off no power or display LEDs. I reset the breaker a few times and it started working again until 2 days ago. Over the last month or so the dishwasher randomly would beep as if someone opened the door with no one around a few times a day but it continued to work so i ignored it.

I have tried resetting the breaker many time, nothing
I checked and made sure the machine it self has power going to the main board through the wired nuts, it does
I took down the main board, and it seems to be a different board then most online diagnosis videos as it does not include a long metal tray more like a square white plastic box
- the LED indicator on the board is blinking very rapidly
I took the door off and checked the wire connection between the main board and the User interface

Then i stopped, how do you decide which part to replace? Im leaning UI
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
Here's the service manual: https://drive.google.com/file/d/1csheGsbSmPFRON5ThkhhwfvZ6saWoxHc/view?usp=sharing

Look at the service manual on page 48. This is ALL it says below. Its very vague and does not tell you how to check for proper UI Board voltage, like the older GE models did.

User Interface (UI) Diagnostics--->No display or LED’s will light.
Check for 120 VAC entering the main control board. If no volts are found, check the home breaker. If main control has 120 VAC, check to see if the service LED on the main control board is flashing. If no, replace the MC(machine control) board. If there is a flash, check the door harness and connections. Replace the User Interface (UI).

Here's the UI Board for your model:

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
Yes, some sites say out of stock, then some sites say: Part WD21X25727 has been superseded to Part WD21X31908.

Jake
 

thestanger

Premium Member
Joined
Aug 16, 2022
Messages
3
Location
nj
Update, i was able to use the machine periodically by shutting the breaker for a few hours and crossing my fingers when i turned it back on. Yesterday i recieved the backordered part, installed it, and still no power. No change.

The LED indicator bulb is still blinking fast, any ideas?
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
That's very odd, the new UI Board should of fixed it.

I'd check the door wire harness too.

Check for a loose connection in the electrical connector pins, one or two maybe not making good contact where it plugs into either of the two boards.

Here's the door wire harness for your model: WD21X10545

If the door wire harness is good, then the only part left that would cause this is the machine control board.

Here's the machine control board(underneath the dishwasher) for your model:
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top