• Please note, some of the links on our site are affiliate links (Learn More)

GE Dishwasher GDF630PSM0SS - UI Board Voltage

lafiddler

Premium Member
Joined
Jun 22, 2022
Messages
2
Location
Louisiana
Model Number
GDF630PSM0SS
Brand
GE
Age
1-5 years
Hi,

My dishwasher UI board beeped randomly, for a while then finally died.

The UI board will not energize. There is no button function, no lights.

Using this forum, I did the following:

Checked voltage to main control board: 120vAC
Checked voltage on the main control board pins 2 and 5 going out to the UI board: 13.23vDC

I ordered a new UI control board, part number WD21X25727. I plugged this part into the harness and it failed to light up as well.

I checked the harness voltage at the UI board, and got 13.23vdc. All the door wires wires have continuity checked with a multimeter.

What's going on? Is 13.23vdc just enough to not energize the system? Ive seen conflicting information showing 13.5, 12-15, 13.37, etc. If this voltage is not enough, I'll need a main control board.

Thank you!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
131,272
Location
Redmond, Oregon

kyalv

Member
Joined
Jun 27, 2022
Messages
1
Location
Sacramento
I am having a similar problem with my UI board. Original main board was 13.4v and the new main board is still getting 13.4v. I have also replaced the UI board twice from appliance parts pros with the same result. New UI wont light up at all but original UI will power up but then turn off after one cycle.
 

lafiddler

Premium Member
Joined
Jun 22, 2022
Messages
2
Location
Louisiana
Hi,

My dishwasher UI board beeped randomly, for a while then finally died.

The UI board will not energize. There is no button function, no lights.

Using this forum, I did the following:

Checked voltage to main control board: 120vAC
Checked voltage on the main control board pins 2 and 5 going out to the UI board: 13.23vDC

I ordered a new UI control board, part number WD21X25727. I plugged this part into the harness and it failed to light up as well.

I checked the harness voltage at the UI board, and got 13.23vdc. All the door wires wires have continuity checked with a multimeter.

What's going on? Is 13.23vdc just enough to not energize the system? Ive seen conflicting information showing 13.5, 12-15, 13.37, etc. If this voltage is not enough, I'll need a main control board.

Thank you!
Thank you. Unfortunately, the part is unavailable until at least august. I'm going to be getting another dishwasher today, as the part is still going to be $200 after shipping and tax. Shame, but the chip shortage is a killer.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
131,272
Location
Redmond, Oregon
I am having a similar problem with my UI board. Original main board was 13.4v and the new main board is still getting 13.4v. I have also replaced the UI board twice from appliance parts pros with the same result. New UI wont light up at all but original UI will power up but then turn off after one cycle.
Then it must be the machine control board(underneath the dishwasher) that is the culprit. I posted the link to it in post #2 if you have the same model number GDF630PSM0SS

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
131,272
Location
Redmond, Oregon
Thank you. Unfortunately, the part is unavailable until at least august. I'm going to be getting another dishwasher today, as the part is still going to be $200 after shipping and tax. Shame, but the chip shortage is a killer.
Your Welcome. Yes, I don't blame you for getting another dishwasher, if the new machine control is backordered till Aug. especially if you use your dishwasher daily, or many times a day.

Jake
 
Top