• Please note, some of the links on our site are affiliate links (Learn More)

GE Dishwasher GDT535PSM0SS no power

tofferdoffer

Premium Member
Joined
Oct 24, 2022
Messages
3
Location
Los Angeles
Model Number
GDT535PSM0SS
Brand
GE
Age
1-5 years
Hello, i found some other related post similar to my issue but not 100% so i thought i would post and ask..

I have the GE GDT535PSM0SS model dishwasher and recently it stopped working. No power on control panel, no beeping, no nothing. I tried swapping outlets and confirming power there and found no issues at the plug. Then i began the troubleshooting tips i found on various post. Most notably i removed the kick panel to check the power coming into the unit. I uncovered the main power; black, grey, white and green, and confirmed that i am getting power coming into the unit. I then checked the power on the main board located under the dishwasher. I found in one of the post a suggestion to check the pins on the board that feed the UI controller up on top; pins 2 and 5, and i can see power register on my mulimeter. But the one thing i found different is there is no blinking light (or any light) on the main control board.

I have heard others speak of it blinking or being a solid green light, but in my case i have no light on it at all. Does this mean that the main control board is bad?

Thanks for any help and i can provide more detail if needed....
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
Yes, the STATUS LED on the machine control board underneath the dishwasher should be flashing at all times.

Look at this thread, same model as yours and same problem:

If your absolutely sure you have 120 volts AC to the machine control board and you see no STATUS LED flashing on it, then its bad.

Here's the machine control board for your model:

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
Ok, sounds good, yes let us know.:)

Jake
 

tofferdoffer

Premium Member
Joined
Oct 24, 2022
Messages
3
Location
Los Angeles
Sorry for the late reply been busy with work.. But i received the new control board and installed it. After getting everything connected and powered back on i was ready to test the dishwasher. I plugged the unit in and the machine did not power up. I checked all the power connections and wiring and everything is connected. I even re-checked the wiring with the volt meter and i got readings from the main power. So at that point i just sort of laid there on the floor staring at everything, hoping my wife would just walk over me and not ask if it was working or not.... Eventually she left me there and went upstairs and it was at that point that i gave up.... Back at work i continued to think about the issue and couldnt recall if the main board did indeed get power.

So days later i removed the main control board that i just installed and i did confirm that it had power; there is a blinking green light. But again there is no power up to the Control UI. Well after that and seriously cutting myself while washing dishes the old fashion way we decided to buy a new machine (my wife decided)...but i was there.....lol

So in the end (i believe), the main board i replaced would have worked if not for another issue with the Control UI board that is on "permanent" back order everywhere.

Jake, thanks for the advice and everyone that has gone before and contributed to these post!!!

Sherman
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
If you feel that you have benefited from this site, and would like to show your appreciation.
Top