• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GE Dishwasher GDT580SMF8ES Won’t run water through spray arms.

jelias

Premium Member
Joined
Jan 10, 2019
Messages
8
Location
Pennsylvania
Model Number
GDT580SMF8ES
Brand
GE
Age
1-5 years
Dishwasher will fill with water at beginning of cycle. Entire cycle will run and drain at the end. Spray arms never come on.

I disconnected water supply and made sure nothing was wrong with incoming water and it was fine.
With the tub filling with water I ruled out water valve?

What confuses me is I put the dishwasher into service mode to try and test cycle everything, and nothing happens. But if I run a cycle everything seems to work except for the spray arms.

Not sure we’re to go from here? Any help would be great.

also to note.
2 years ago had a bad wire going to soap dispenser ended up replacing main board before I found the broken wire. Also had the float switch go bad.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,812
Location
McMullen Valley, Arizona
Hi,

The circulation wash motor is the only part that forces water through the spray arms to make them run and turn, so apparently the circulation wash motor is not running.

Here's the service manual for your model: https://drive.google.com/open?id=1Fefp5_Ibg86DtJhjwzL5kPqGBSicyP1v

Go to Page 77--->Circulation Diagnostics, then do the flowchart and let us know what you find.

Here's the circulation wash motor for your model:


Jake
 

jelias

Premium Member
Joined
Jan 10, 2019
Messages
8
Location
Pennsylvania
when I go into service mode I can get the blinks to indicate what cycle is trying to happen. But nothing happens.

so testing the circulation pump this way is a no go.

when I run a cycle it seems everything works as it should except for the circulation pump.

is it possible the board is bad?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,812
Location
McMullen Valley, Arizona
Ok, on the flowchart it first says: ENTER SERVICE MODE Unit Fills and Drains OK--->Is wash motor operating?

So the answer is NO?

Next it says if NO:
Screenshot 2021-06-15 21.11.12.png


You will need a multimeter to check the volts like it says to do.:)

Hate to see you order a control board and it not fix it, and once you install it you can't return it.

Jake
 

jelias

Premium Member
Joined
Jan 10, 2019
Messages
8
Location
Pennsylvania
Ok, so finally got a chance to look at this some more. I ordered both the board and circulation pump last week and got them today. Entered service mode and got everything the work, had 120v to circulation pump but no spray so I replaced it, and hoping to return the board.

So after pump replacement I go back into service and it seemed to be working, I should have let it run a little longer, started a cycle and it leaked… so I dried out the pan go to put the dishwasher in service mode to see where it’s leaking and no power to the door. Looked at service light on main board and I’m getting 7 blinks. Nothing in service manual for 7 blinks. So for tonight I’m done. Turned off breaker and letting it dry out hoping tomorrow I come home and it works. 🤣

Any idea what the 7 blinks would be?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,812
Location
McMullen Valley, Arizona
Glad to hear the new circulation wash motor fixed it.(y)

Access the main control board and view the service LED. If it is flashing 7 times within 3 seconds, the CSM is tripped.

The CSM tripped because of the water leak you have, you will need to fix the water leak and reset the CSM and that should get you back to normal.:)

To reset the CSM.
Entering Service Mode will reset the CSM.
To enter Service Mode :
1. First enter Consumer Error mode. After the ten (10) second door check has completed, continue to next step.
2. Enter Service mode (while in Consumer Error Mode), by pressing and holding the Select Cycle button for five (5) seconds.

Enter Consumer Error Mode:
Press the Select Cycle and Start buttons at the same time for Five (5) seconds. If the control responds with LED’s or Display coming on, The CSM is tripped.

Jake
 
Top