• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GE Dishwasher GDT665SSN2SS stops midcycle

sgopalan2012

Premium Member
Joined
Aug 29, 2022
Messages
4
Location
New Jersey
Model Number
GDT665SSN2SS
Brand
GE
Age
1-5 years
Model: GDT665SSN2SS
Serial: GR719030B

Initial Problem:
  • Our GE dishwasher stopped working mid-cycle and also intermittently showed an error code of H20
  • A GE service technician came onsite, found that the water tank was filling up and said that the problem was with the control board
  • He ordered a replacement control board (Part WD21X25992)
  • I decided to replace the control board myself and followed the instructions on a youtube video
  • After replacing the control board, the dishwasher worked fine for 3-4 days

Current Problem
  • 3-4 days after replacing the control board, the dishwasher stopped mid-cycle
  • I looked online and there were suggestions that it might have been a defective control board unit that was sent.
  • I requested a replacement of the same control board and installed it again
  • However, the dishwasher still stops mid-cycle

Things I've checked
  • I entered service mode and selected mode 2. After it ran, I verified that there was some water at the bottom of the tank
  • I also checked circulation mode (mode 3) and I could hear the water moving around during that part of the cycle
I'm not really sure what else to check

Thanks!
Sid
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,162
Location
Redmond, Oregon
Hi Sid,

Yes, Disconnect power to the dishwasher, then pull the pressure sensor out and clean it and see if the fixes it.

Look at my post #3 here:

Here's the pressure sensor for your model:

For others following your thread--->Watch this video to access it:


Let us know how it goes.

Jake
 

sgopalan2012

Premium Member
Joined
Aug 29, 2022
Messages
4
Location
New Jersey
Thanks Jake! I pulled out the pressure sensor and cleaned out the gunk from the sensor but the dishwasher still doesn't work.

I noticed that it doesn't progress past the first minute of the cycle. For example, I start the light cycle (51 minutes) but the dishwasher timer stops at 50 minutes. I think it also keeps trying to drain the water even though the dishwasher is empty.

I retried service mode and confirmed the water fills up (mode 2), circulation works (mode 3) and the drain (mode 1) also seems to work.


Any other suggestions?
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,162
Location
Redmond, Oregon
Then that control board you ordered has to be the culprit, where did you get it at?

Here's the machine control board for your model:

Look here:

Jake
 

sgopalan2012

Premium Member
Joined
Aug 29, 2022
Messages
4
Location
New Jersey
I took another look at the pressure sensor today. Last time, I hadn’t removed it from the mount when cleaning it. I removed it, cleaned it thoroughly and the dishwasher is working now!

Thanks so much for your help Jake!
Sid
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,162
Location
Redmond, Oregon
Excellent Sid, glad to hear that.(y)

Thanks for the update!

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top