• Please note, some of the links on our site are affiliate links (Learn More)

GE Dishwasher (Model GDF640HSM2SS) has no power on buttons at all

Alley

Member
Joined
May 27, 2022
Messages
1
Location
California
Model Number
GDF640HSM2SS
Brand
GE
Age
1-5 years
Hi! Yesterday night my GE Dishwasher (Model GDF640HSM2SS) became non-responsive. The controls/buttons on the front has no light display at all. I checked breaker in main electrical panel and it is not tripped. We are having some construction work going at our place and guys have to draw electrical power from the main panel directly. Sometimes lights in the house flicker little bit when they are using electrical power. I wonder if that caused some electrical issue for my dishwasher. I bought this dishwasher just over 2 years ago so I don't think age is the issue. Based on online research I did CSM Tripped steps i.e. hold 'Select Cycle' and 'Start Button' for 5-10 buttons but lights on the control panel didn't come back. Any help would be appreciated. Thanks!
 

Attachments

  • IMG_4201.JPG
    IMG_4201.JPG
    378.1 KB · Views: 50
  • IMG_4202.JPG
    IMG_4202.JPG
    265.2 KB · Views: 50

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon

Taylorbg54

Premium Member
Joined
Jun 20, 2022
Messages
2
Location
Texas
Hi. I have the same dishwasher model number and it’s doing the same thing. I checked the power and it’s good. I pulled the control board and it’s continually blinking. What would you suggest next?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
I have the same dishwasher model number and it’s doing the same thing. I checked the power and it’s good. I pulled the control board and it’s continually blinking.
Ok, that indicates your machine control board under the dishwasher is working.

What would you suggest next?
Look at the service manual I posted the link to above, on page 48. This is ALL it says below. Its very vague and does not tell you how to check for proper UI Board voltage, like the older GE models did.

User Interface (UI) Diagnostics--->No display or LED’s will light.
Check for 120 VAC entering the main control board. If no volts are found, check the home breaker. If main control has 120 VAC, check to see if the service LED on the main control board is flashing. If no, replace the MC(machine control) board. If there is a flash, check the door harness and connections. Replace the User Interface (UI).

Here's the door wire harness for your model:

Here's the UI(User Interface) Board for your model you can order, if the door wire harness is good:

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
Ok, sounds good, let us know what you find. If the door harness wires and connections ohm test good, then you shouldn't need to order a new door harness, the problem per the service manual says to Replace the User Interface (UI).


Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top