• Please note, some of the links on our site are affiliate links (Learn More)

GE Gas Dryer Digital GTD84GCPN1DG wont turn on at all...??


Premium Member
Nov 26, 2021
Model Number
1-5 years
Model number GTD84GCPNDG GE gas dryer with digital display wont turn on. I checked the power supply, thats not the issue. I tried everything and it wont turn on, nothing at all on the display board. Stopped working mid cycle. I have no idea what to do and Google and YouTube aren't showing anything that could be wrong except the display board needs to be replaced? Its only 2 years old. Does anyone know of a way to check to see if its the display board? I'd rather not spend 100 something dollars for a new one and it be a simple cheap fix.

Added complete model number
Last edited by a moderator:
Your missing a digit in your model number. Read it from the model number tag on the machine, which should be located inside the door.

Here's the results I get:

When you open the dryer door does the drum light even come on at all?


Then it sounds like your wall outlet is not getting power.

Plug a hair dryer into that exact same wall outlet and see if the hair dryer works.

I plugged our washer into the same outlet and the washer turns on. Even tried a different power source and still will not turn on.
Ok, I'd next check the power cord into the dryer to make sure your getting 120 volts with a multimeter, where the power cord connects inside the dryer.

Here's the power cord for your model:
Power Cord (120V Gas) WE26M345

This video gives you the general idea of how to take your dryer apart to check where the power cord connects inside the dryer. Make sure you unplug the power cord from the wall outlet first before you take the dryer apart.

Definitely not the power cord, got a little shock when touched the sensor accidentally. So its getting power through the cord for sure.
Ok, I couldn't locate the service manual or tech data sheet for this model. See you can locate yours, it should be inside the control panel and read what it says to check when it all goes dead.

Its possibly the control board that's bad.

Here's the control board for your model:

JHuston, Did you ever figure out what was wrong? Did you need a new control board? I have the same problem right now with the same dryer model. 16 month old dryer GTD84GCPN1DG went from functioning fine to not able to power on, and I've determined the power source is not the issue.
Thanks for the tech sheet! Hugely helpful! Where do I go from here if I can’t get CEM mode or field service mode to activate (both of which require the power button to do anything). The power button sounds the same (I can hear the slight click when depressed), but there is no activation of power to the machine.
If you feel that you have benefited from this site, and would like to show your appreciation.