• Please note, some of the links on our site are affiliate links (Learn More)

GE GDF620HMJ2ES Dishwasher no power

Status
Not open for further replies.

TMiller85

Member
Joined
Sep 2, 2020
Messages
1
Location
Philadelphia, PA
Model Number
GDF620HMJ2ES
Brand
GE
Age
1-5 years
Hello. I am hoping for some advice. I think my issue is very similar to the thread below that was already solved. I just want to provide some details about my specific situation to see if the same solution is recommended before I purchase any parts.


I purchased this dw about 4 years ago. Within the last 6 months, I have had some issues with the power shutting down near the end of the wash cycle. Several of those times, there was about two inches of water left in the tub. The quick fix has always been to reset the circuit breaker. After doing that, the dw would turn back on. That has always worked, until now. A few other issues I've noticed is 1) the dw just randomly beeps while not in use, and 2) the "clean/santized" button no longer lights up after the cycle.

Anyway I followed the suggestions in the above thread to diagnose the issue. I was able to access the control panel and found the LED solid green light, so that seems to be ok. Based on the recommendations, that makes me think the U/I needs to be replaced. That said, I had a local appliance repair tech stop by today. He barely looked at the dw and instead, said it's likely the control board and not the U/I, despite me explaining the above. I realize there are no guarantees, but I just wanted to get some input before ordering the U/I part.

This dw color (slate) matches the rest of our appliances and it seems to be out of stock everywhere right now. So it's either fix this one, wait months to find a replacement, or get all new appliances. I would like to choose option A if possible. :) Thank you in advance for any advice.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
114,577
Location
McMullen Valley, Arizona
Hi,

Like I mentioned in that other thread: If the STATUS LED is still SOLID GREEN(STEADY ON), then its likely a bad UI(User Interface) Board.

Here's the UI(user interface) Board for your model you can order: WD21X23462 Kit Svc Ui Top Logic

You can verify that will a multimeter. The UI operational voltage is output from the main control on connector J722 pin 2 black/green to pin 5 yellow/blue. If 13.5 Volts DC is NOT there, replace the main control.

If 13.5 Volts DC is there, replace the UI Board.:)

Snapshot_2 (1).jpg


That J722 connector is on the other side of the control board, look here:

J722.jpeg


It's the one on the left above the ethernet port.:)

Let us know what you find.

Jake
 
Status
Not open for further replies.
Top