• Please note, some of the links on our site are affiliate links (Learn More)

GE GDF630PSM0SS dishwasher has no lights, unresponsive

rlaflamme

Premium Member
Joined
Jul 12, 2022
Messages
4
Location
01851
Model Number
GDF630PSM0SS
Brand
GE
Age
1-5 years
Hi there! Hopefully someone with more knowledge on these units than I can point me in the right direction on where my issue may be :)

We currently own a GE GDF630PSM0SS that's about 3 years old. Until today it's never given us any issues, but suddenly the unit is completely unresponsive and is showing no power or lights on the LED panel.

As a result the self-diagnostic CSM option is not available.

I have been able to confirm that there is power getting to the unit itself, and there's no indication of any loose connections or water affecting anything. Opening up the main control board is showing a single green LED that flashes rapidly when power is connected. (Not sure if it's supposed to be a solid state or continual steady blinking but this one is rapid in nature.) I also removed and tested connectivity with the fuse itself for the heck of it and that came back fine as well.

My question then is: based on that behavior is the issue likely residing with the main control board, the door's UI board, or something in between?

Any help to that end would be appreciated. Thanks!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,144
Location
Redmond, Oregon

rlaflamme

Premium Member
Joined
Jul 12, 2022
Messages
4
Location
01851
Hi Jake,

Thanks for the reply. I found that section but regrettably the self-diagnostics isn't possible as I have no lights or power on the front panel. It's completely unresponsive. The only sign I get that power is connected on the unit (other than the 120V right at the wiring) is the aforementioned light on the main control board.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,144
Location
Redmond, Oregon
Page 46--->You do have a CSM on this model, did you turn the power off to the dishwasher for a few minutes and turn the power back on again and see it that resets it?

Then look on Page 48:
Screenshot 2022-07-13 12.53.39.png


I'd check the door wire harness too.

Check for a loose connection in the electrical connector pins, one or two maybe not making good contact where it plugs into either of the two boards.

Here's the door wire harness for your model: WD21X10545

Here's the UI Board for your model:

Jake
 

rlaflamme

Premium Member
Joined
Jul 12, 2022
Messages
4
Location
01851
Thanks Jake.

The cabling on the central board end looks fine, nothing loose or out of sorts. I'd have to open up the door to get a look at the other end.

Before I tackle that though, I happened to see another thread on here regarding a similar issue with the same model, and it was suggested to check the 2/5 pins on the door harness pins on the control board for voltage. I did and it comes back with a pretty steady 13.24 VDC. But if my understanding is correct, that's probably not good, no?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,144
Location
Redmond, Oregon

rlaflamme

Premium Member
Joined
Jul 12, 2022
Messages
4
Location
01851
Thanks Jake. Glad to know I was on the right track - though from the sounds of it getting the board could be a challenge. But one thing at a time.

Thanks again.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,144
Location
Redmond, Oregon
Yes, hopefully its a short wait until the machine control board comes back in-stock.

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top