FIXED GE GDT580SSF0SS heater not coming on - tried multiple things - next steps??

Bdogggut34

Premium Member
Joined
Jan 10, 2018
Messages
17
Location
OH
Model Number
GDT580SSF0SS
Brand
GE
Age
1-5 years
I have a GE GDT580SSF0SS dishwasher. It was here when we purchased the house and worked just fine for 3 years we have been here. However sometime in the last 3 months the heater element stopped coming on. Choosing all options including heated dry, the element is cool to the touch when opened immediately or during the cycle and dishes no longer dry.

Here is what I have done:
1. Replaced the heat element even though the other one seemed to test ok. I have checked all wiring all the way to the plug going into the control board and I read 16.2 ohms at that plug. I did a negative check and removed a wire on the element and it drops out so I know I have continuity.
2. Replaced the control board. Figured this was the issue then however a new board and no changes.
3. Found the paper on how to run diagnostic so ran it into service mode. Was able to get the pump to come on, fan, fill up and drain however when running the mode to ‘turn heat element on for 2 mintues’ it stays cool to the touch.

I understand and see there is the thermal switch that rests up against the bottom of the tub. Not sure how to test this but as mentioned I have 16.2 ohms at the plug to the board so I know there is continuity through it. Not sure how it works but there is a small button on the back of it that stays down and can be pushed up. I’ve check it both ways and even when you push it up the ohms and continuity stay the same.


I’m out of ideas at this point, anyone have any clue what to do next?
 

Bdogggut34

Premium Member
Joined
Jan 10, 2018
Messages
17
Location
OH
One other question, the Thermal Cutout on this model unfortunately is not sold separately and part of the wiring harness for the entire pump kit which is $200. My question is, I see replacement Thermal cutouts for other dishwashers such as Whirlpool and believe I could just re splice one of these in place, is that correct? They look in general the same and work the same as in opening when the temperature gets too high.
 

Bdogggut34

Premium Member
Joined
Jan 10, 2018
Messages
17
Location
OH
Sorry I keep replying to my own thread but have done some more testing. The element itself reads 16.2 ohms and was able to measure across the TCO only and reads .1 or so so I think this is good. At this point have no ideas what else to test or what else to do.

Reading other threads. Also have cleaned the fill valve and taken out the turbidity sensor and made sure all was clean and good. No clue what to do. So weird it just stopped on us and after what i’ve done still cant get the element to come on, even in the diagnostic mode.

Anyone have any help?
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
34,386
Location
Murray, Utah 84107, United States
I don't how we missed this. Sorry about that my friend. OK, You're on the right track so let's see if we're on the same page. I'm working off a tech sheet for a similar model (GDT550). Simultaneously press and hold the "select cycle" and the "start" pads for 5 seconds. This is error code mode. The control will check the door status for the next 10 seconds. LED's solid=door closed. LED's flashing=door is open. After that the only LED lit should be "Locked". If any other LED is lit, that's an error.
error code.jpg

You said you replaced the control board. Check the personality connector is set correctly. There should be a sticker next to the control board with the configuration diagram.
personality.jpg

If anything, 16.2 is low. Check the heater circuit at the control board J702-1 and J702-2. If the element is dry your meter should indicate 23.4 ohms. Wet 18.1 ohms. If you're still getting 16.2, measure the resistance of just the element. Reset the TCO. The TCO should measure 0 ohms. Always remove at least one wire when checking for continuity. If your meter has a continuity setting, 0 is closed and 1 is open.


Check for a pinched wire where the wire harness goes into the control board compartment.
Pinched Wire.jpg

On the control board is a status LED. See if it's blinking.
Status LED.jpg
 

Bdogggut34

Premium Member
Joined
Jan 10, 2018
Messages
17
Location
OH
Yes the first thing you describe is correct. Once complete only the lock button is lit so no codes. Going further I hold ‘Select Cycle’ for 5 seconds and enter service mode. 4 blinks is the heater and when I run that the heater does not come on. All other items such as fan, pump, etc...come on when I perform this.

I checked the board and the personality spot on the board does not have anything for selection. It looks simply like soldered spots on the old and new board, they are the same. Although it looks like the picture you put in the post it does not have any selectable pins. It does say ‘personality’ right on the board so I know i’m in the right spot.

I measure 16.2ohms on the element only underneath the dishwasher with all leads disconnected. I connect the leads to the element and still measure 16.2 ohms at the board connector. I even put a wire to temporarily bypass the TCO (even though I measure 0-.1 across the TCO) and ran the service mode and still does not come on. I saw on the information sheet the 23ohms and 18ohms but this is a brand new element and the old element measured 18ohms if I recall. Not sure how that affects anything.

Unplugged and double checked all wires coming through and no pinches.

Control board status LED, when I first dropped it it was blinking 5x per 3 seconds. After running service mode it is now blinking 1x per 3 seconds.

Any next thoughts? I’m really dumbfounded since it worked for 3 years just fine and all of a sudden nothing.
 
Last edited:

Bdogggut34

Premium Member
Joined
Jan 10, 2018
Messages
17
Location
OH
Check the heater circuit at the control board J702-1 and J702-2.
Can you explain a little more about what to do here? Should I be reading a certain AC or DC voltage at the pins on the board itself? Should this change when I try to put it in service mode and activate the heater?
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
34,386
Location
Murray, Utah 84107, United States
The heater circuit starts at the board J702-1 down to the TCO, through the TCO, out to the element, through the element, and out to the J702-2 connector. The entire heater circuit consists of, control board, TCO, element, and 3 lengths of wire. One of those is bad or not working. Set your meter to measure VAC. Disconnect the two wires on the element and connect them to your meter leads. Start a cycle with wash boost and heated dry. Watch for 120 VAC.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
101,466
Location
McMullen Valley, Arizona

Bdogggut34

Premium Member
Joined
Jan 10, 2018
Messages
17
Location
OH
The heater circuit starts at the board J702-1 down to the TCO, through the TCO, out to the element, through the element, and out to the J702-2 connector. The entire heater circuit consists of, control board, TCO, element, and 3 lengths of wire. One of those is bad or not working. Set your meter to measure VAC. Disconnect the two wires on the element and connect them to your meter leads. Start a cycle with wash boost and heated dry. Watch for 120 VAC.
Looking at the diagram I see exactly what you describe so figured this would be easy :). I think I was wrong.

Ok, so disconnected the element and put my Fluke on the leads coming from the board. When water is coming in it shows 1.8 VAC, when water circulates it shows 2.6 VAC, when draining it shows 5.2 VAC and when finished it shows approx 6 VAC. I put it in the min/max setting and 6VAC was the max. Doesn’t seem like i’m getting the output at all. Have no idea what kind of logic is in the board but something else has to be wrong and not allowing the element to come on. I would have thought the board was the issue but hard to believe I would have the same issue with a brand new board....but then again i’m not an appliance expert.

Also I have taken out and fully cleaned the flood switch. It was gunked up a little but I can hear a float move around in there so seems to operate properly. The water level is normal as shown on the owners manual.

Any other thoughts?
 

Bdogggut34

Premium Member
Joined
Jan 10, 2018
Messages
17
Location
OH
Jake: I saw the first thread you mentioned so decided to take the float switch out completely and clean everything. The float switch was gunked up a little but was able to completely clean it and moving it around sounds like the float freely moves in there.

The model I have does not have a hidden heater as the element is exposed at the bottom of the tub.

I cleaned it and ran a Normal cycle with wash boost and heated dry and the element is cool to the touch. Also tried the service mode again with 4 blinks and it stays cool to the touch with no voltage change. I’m clueless
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
34,386
Location
Murray, Utah 84107, United States
It sounds like the new control board is faulty. If you got it from a link on this site return it for a replacement board.
 

Bdogggut34

Premium Member
Joined
Jan 10, 2018
Messages
17
Location
OH
Thanks to everyone for your help. I have a new board on the way (got it straight from GE at a discount and they have been super responsive and sending me a new one) and since I can return it at any point I ordered a new float switch from repair clinic.com. Reason being, in searching I found a full technical service guide that would have been extremely helpful starting off. In the drying section troubleshooting workflow, it does say measure the resistance of the thermistor which is located in the float switch. I should read 11kOhms at normal 75 but am reading about 1.6kOhms which on the chart shows a temp of almost 175. It doesn’t say specifically what this does other than give temp but at 1.6kOhms its constantly thinking 175 water temp. The workflow says if I don’t read 11k-12k then replace the float switch, this is for both exposed and hidden heater.

I will report back when parts come in later this week. This link below extremely helpful for someone else, here is where I found the tech service manual outlining everything.

https://www.applianceblog.com/mainforums/attachment.php?attachmentid=35623&d=1510761784
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
101,466
Location
McMullen Valley, Arizona
Excellent, yes, please keep us posted.:)

I'm 100% sure you will fix it with either the new control board or flood(float) switch.

Jake
 

Bdogggut34

Premium Member
Joined
Jan 10, 2018
Messages
17
Location
OH
FIXED! The float switch! There is a thermistor in this that read water temp and that failed.

I replaced it and measured the resistance at the pins for the thermistor and got 12.7k ohms as the guide said. (Previously read 1.6k Ohms and according to the chart that was showing 175 degrees for the water temp). I don’t think anyone will ever see logic in the board but that thermistor will not allow the heating element to come on if the water reaches a certain temp, even with an exposed heater like my model has, not just the hidden.

Thanks again to everyone for your help!
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
101,466
Location
McMullen Valley, Arizona
Excellent, glad the flood(float) switch fixed it.:)

Thanks again for the update!

Jake
 

JHBlake

Member
Joined
Dec 22, 2018
Messages
1
Location
Weiser, ID
Hi Guys,

Just what to mention the flood switch. I've found a few that it was the flood switch causing this "no heat" problem.

Here: FIXED: GDT580SGF0WW GE dishwasher not heating, tried several things, What's next?

He found it was the flood switch had crud/gunk on it keeping it from heating.


And Here: FIXED: GE Dishwasher - CDT765SSF0SS - Not heating/drying

He replaced the flood switch and that fixed it too.

Your model uses the exact same flood switch:
WD21X10519 Switch Flood Asm


Jake
My 2.5 year old GDT580SGF8WW had stopped heating. After reading this and a few other threads, I purchased the flood switch assembly via the link, installed it, and everything is working fine again. My wife thanks you.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
101,466
Location
McMullen Valley, Arizona
Excellent JHBlake, glad to hear the new flood switch fixed yours too.:)

Thanks for letting us know!

Jake
 

bhatcher

Member
Joined
Feb 22, 2019
Messages
1
Location
tx
Hey guys, I just wanted to say thanks. I have been struggling with my 3 year old dishwasher (same model as OP, GDT580SSF0SS) - about 2-3 months ago it stopped heating, just as described in this post.

I had taken a lot of the same steps, measured a lot of the same components and still couldn't figure what was going on.

I was on the brink of ordering a replacement control board when I stumbled across this post and could tell immediately based on what was described that this was what I was up against.

I replaced the flood switch and sure enough, it works like a champ! Thank you all for taking the time to help others troubleshoot and diagnose these kinds of problems.

They are frustrating and potentially expensive - y'all saved me a lot of money and additional wasted time, so a big thanks to all who helped and took the time to post!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
101,466
Location
McMullen Valley, Arizona
bhatcher: Glad to hear the new flood switch fixed yours too.:)

Thanks for letting us know!

Jake
 
Top