FIXED GE GDT580SSF0SS won't start

delk

Premium Member
Joined
Apr 30, 2019
Messages
5
Location
NC
Model
GDT580SSF0SS
Brand
GE
Age
1-5 years
Age is 5 years next month.

I have a GDT580SSF0SS which won't start. When I enter error mode it fails the door latch check, all lights remain blinking regardless of if the door is open or closed. The status LED on the control board blinks 1x per 3 seconds.

I ordered a new door latch and replaced it today and nothing has changed.

Where to go from here?

Thanks.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,345
Location
McMullen Valley, Arizona
Hi,

Ok, it says 1x per 3 seconds: Unit is not running a cycle, select a cycle and press start.

If that does not work, do this: Hold "Heated Dry" and "Start" for five seconds then try it.

Jake
 

delk

Premium Member
Joined
Apr 30, 2019
Messages
5
Location
NC
Hi Jake, the light on the control board still blinks 1x per 3 seconds even when selecting start and closing the door.

I held heated dry and start together and nothing happened. Start is illuminated and the light on the control board still blinks 1x per 3 seconds.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,345
Location
McMullen Valley, Arizona
Ok, that indicates Communications Failure, User interface unable to communicate with the control board.

Since your control board is not showing a control board error, then it must be a bad user interface. There is a how to replace it video in the part link.

Here's the user interface for your model:
User Control and Display Board WD21X22177


Jake
 

delk

Premium Member
Joined
Apr 30, 2019
Messages
5
Location
NC
Hi Jake, I ordered a WD21X22177 and replaced the old user interface board today. However now I have no power to the user interface board when turning on the breaker. The control board continues to blink 1x per 3 seconds.

I pressed and held select cycle and start for 5 seconds and nothing happened, still no lights or sounds from the UI board.

The new UI board had jumpers where the old part did not. I jumped 8, 4, 2, and not 1 as indicated on the instructions for my GDT580.
 

delk

Premium Member
Joined
Apr 30, 2019
Messages
5
Location
NC
Ok maybe I just didn't give it long enough or something, because now the new UI board has power. However it's still failing the door test, same as the old board. All lights remain blinking when pressing select cycle and start whether or not the door is open or closed.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,345
Location
McMullen Valley, Arizona
That's very strange, then it has to be a bad control board. You can return the User Control and Display Board for a full refund, less shipping. But you may want to hold on to it until you get the new control board, then put your old User Control and Display Board back in place and see if your back in business, if so then return it.

Here's the control board for your model you can order:
Control Board WD21X22276


Let us know how it goes!

Jake
 

delk

Premium Member
Joined
Apr 30, 2019
Messages
5
Location
NC
Installed the new control board today, now it passes the door test and everything seems to function as expected. Haven't run yet but if no further updates assume it's good as new.


Thank you for your help!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,345
Location
McMullen Valley, Arizona
Excellent delk, glad to hear that.:)

Thanks for the update!

Jake
 
Top