• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GE (GTW330ASK3WW) top loader sits idle after wash cycle

LeonardGE

Premium Member
Joined
Aug 11, 2022
Messages
3
Location
Michigan
Model Number
GTW330ASK3WW
Brand
GE
Age
1-5 years
I have a GE (GTW330ASK3WW) top loader that fills with water, agitates and then stays idle indefinitely with "Wash" light on. You can manually turn the knob to the next cycle and it will spin but does not sound normal.
I have:
  • When you manually advance to spin cycle or during diagnostic test, the lid locks like normal.
  • Checked/clean the drain-line from the pump and beyond.
  • Removed the pump (no obstruction) and cleaned.
    • the impeller does not spin freely... you can spin it completely but it seems to clunk into different stages, is this normal?
    • I performed the pump test diagnostic and you can hear the pump whirring but does not drain water out of the drain-line.
      • When you start the error code diagnostic, the Fill and Rinse lights blink... lights 2 and 5.
  • Checked the belt (nothing abnormal)
  • There seems to be water still in the machine somewhere that you can feel sloshing around when tipping over to access underneath.
    • The machine is loud when manually put into Spin cycle, is this because it has not drained and there is still water present?
I appreciate any insight!?!?
 
Last edited:

LeonardGE

Premium Member
Joined
Aug 11, 2022
Messages
3
Location
Michigan
When you say "Removed the pump and cleaned" do you mean you disassembled the pump and cleaned it?
That is correct, I removed it, disassembled it (no major obstruction), cleaned it, assembled it and installed it.

I was able to get the machine to both spin (I hear grinding and machine is louder than normal) and drain (tons of water pressure coming out of the drain line) for several cycles by manually advancing the machine to "Drain and Spin". After several cycles it stopped working and would not drain or spin... you could hear the pump hum and then nothing. I reset the machine and just got it to drain and spin (after pump humming)... but it still sounds loud and grinding when spinning. I also observed a small amount of water coming out of the right side of the machine but have not investigated yet.
 

jmartin919

Premium Member
Joined
Aug 11, 2022
Messages
3
Location
Durham NC
Error code 2 and 5 points to the pump. Did you check error codes today after running the recent tests? Did you run the pump with it out of the machine so you can watch the impeller?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,371
Location
Redmond, Oregon
  • the impeller does not spin freely... you can spin it completely but it seems to clunk into different stages, is this normal?
  • I performed the pump test diagnostic and you can hear the pump whirring but does not drain water out of the drain-line.
Yes, the problem is the drain pump, I've run into this issue a few times on my service calls.

Here's the Drain Pump for this model:
WH23X28418 Drain Pump


This video shows you how to replace it:


Jake
 

LeonardGE

Premium Member
Joined
Aug 11, 2022
Messages
3
Location
Michigan
Thank you for your help.
The new pump came in and I installed it yesterday. Now that it had sat a bit, there was water stains on it which was a giveaway for the leak too. The belt did not look bad but there was some belt shavings in the belt cover case so I replaced that as well while I was under there.

Everything runs great now.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,371
Location
Redmond, Oregon
If you feel that you have benefited from this site, and would like to show your appreciation.
Top