• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GE GTW680BSJ5WS Top Load - H2O Supply Error, also water was dripping from the soap dispenser and into the tub

Status
Not open for further replies.

Hamhocs

Premium Member
Joined
May 16, 2022
Messages
3
Location
WV
Model Number
GTW680BSJ5WS
Brand
GE
Age
1-5 years
My wife said the last couple of loads have ended with very wet clothes in the tub. I found that water was dripping from the soap dispenser, so they were probably sitting in the tub for a while and being dripped on. I found a couple other posts here about that and ordered a new inlet valve from the link provided. Turning off and on the supply lines, it appeared to be only the hot water dripping. So I left that one off. Wife tried to run a load using cold water setting only but it then came up with an H2O Supply Error. I then turned the hot water back on, restarted and got the error message again. When I get the new inlet valve is that likely to fix this?
 

Hamhocs

Premium Member
Joined
May 16, 2022
Messages
3
Location
WV
I tried to run it again las night after letting it sit unplugged for a couple hours. It would just spin for 3 seconds with the SENSING message. Over and over and over. It poured a little water in on the 2nd spin but none after that. So I just shut it down again. It is not leaking anymore after unplugging it either. Hopefully its just the valve that is all messed up.


The good news is that the valve I ordered yesterday from AppliancePartsPros at 1230 pm is out for delivery today! I am impressed. Hope this fixes things.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,144
Location
Redmond, Oregon
Yes, when water is dripping into the tub when the machine is not in use, that's always the water inlet valve that is bad.

Here's the water inlet valve for your model, in case others need it too:
WH13X26637 Valve Quad Water Asm


This video shows you how to replace it:


Let us know how it goes.

Jake
 

Hamhocs

Premium Member
Joined
May 16, 2022
Messages
3
Location
WV
All fixed! I did notice that the orange tube was loose after I replaced the valve. I probably did that during the process. I was able to get a good view in the video above where to put that back. Thanks Jake!

Still can't believe how fast it got here and I chose the cheapest shipping option.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,144
Location
Redmond, Oregon
Excellent, glad to hear the new water inlet valve fixed it.(y)

Thanks for the update!

Yes, AppliancePartsPros has fast shipping.:)

Jake
 
Status
Not open for further replies.
If you feel that you have benefited from this site, and would like to show your appreciation.
Top