• Please note, some of the links on our site are affiliate links (Learn More)

GE Model JS660SL1SS Range Oven not heating properly

tlh3333

Member
Joined
Nov 17, 2021
Messages
1
Location
Nicholasville KY
Model Number
JS660SL1SS
Brand
GE
Age
1-5 years
Hello all

We have a GE slide in range (model JS660SL1SS) that is having issues properly baking things. We first noticed that, when baking food from frozen for the appropriate time, contents would not be properly baked. When setting the oven to bake, the display shows the initial preheat temperature rise all the way to the desired baking temperature.

Holding my hand in the oven, it feels as if the bottom baking element is getting noticeably less hot than the broil element up top (this is on the baking setting not broil). I am ordering an oven thermometer but just going off feeling, the bottom of the oven is noticeably less hot. I checked the error codes on this model and the only error code that reads is a F100 code that I have read is not an issue.

My initial instinct was to order a new bottom baking element but I stopped to reconsider. The oven reads that it is heating properly to the temperature set. Would this indicate that its an issue with the thermometer instead? Or perhaps both? Any additional troubleshooting tips or thoughts would be much appreciated. Thank you!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,425
Location
McMullen Valley, Arizona
Does the bottom bake element get RED hot in COLOR?

Here's the bottom bake element for your model:
Bake Element WB44T10060


I'd disconnect power to the range and ohm test the bake element, watch the video below:


Jake
 
Top