• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GE PDF820SSJ0SS beeps three times per minute - replaced control board

cninham

Premium Member
Joined
Jun 19, 2009
Messages
23
Location
Saint Augustine, FL
Model Number
PDF820SSJ0SS
Brand
GE
Age
1-5 years
I have a GE PDF820SSJ0SS dishwasher. When I attempt to start a wash the dishwasher it will beep about three times every minute. I already replaced both the control board (WD21X24902) and door latch, but the same error still persists -- beeping three times every minute after pressing start button. I noticed that after replacing the control board with a new control board, when I would open or close the dishwasher door (and click the door latch) the status lights on the outside of the door remain off. Normally when you open or close the door, the status lights will turn on... The status lights will only turn on (eg where you select the cycle, water temp, washing zone) after you press the start button. Is it possible that I received a defective control board?

Thank you for your help and advice!

Cameron
 

cninham

Premium Member
Joined
Jun 19, 2009
Messages
23
Location
Saint Augustine, FL
@Jake -- I really need your help, please. I ordered two and replaced both [new] control boards WD21X24902, I also replaced the door latch WD21X10490, nothing resolved my issue. I checked the LED on the control board -- LED is a solid green when power on and door open. LED remains a solid green when I select a cycle and press start.

I searched some other threads, and I followed your direction to check the status of the door latch and continuity of the wiring/door latch switch on jumper J711:


jumper 711 continuity test between pin 3 (tan/red) and pin 4 (violet/yellow) -- open when door is open, closed (continuity) when door closed
jumper 711 continuity test between pin 3 (tan/red) and pin 5 (white/silver) -- open when door is open, closed (continuity) when door closed

I also entered Error Mode, press and hold Cycle Select and Start simultaneously for 5 seconds with door open:
Door open: All LED's flashing
I close the door
Door closed: ALL LED's continue to flash indicating door is open (but it is closed, and according to my J711 jumper test the latch correctly shows door open and closed status.)

I am stumped. I do not know what else to look at.

Any help/guidance is appreciated, please!!!

Oh, I just remembered: do not know if this is the cause of the problem: issue started after I opened the dishwasher and found a metal fork lying on the tub and touching (against) the heating element...???

PLEASE HELP!

Thank you -- Cameron
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
Hi Cameron,

Here's your service manual: https://drive.google.com/file/d/1vUUXq54uhVXGMWX7DylkrOWz_L7v-21P/view?usp=share_link

Look on Page 50 and do the voltage test to the UI Board. Here's the UI Board for your model: Configured Ui Board WD21X32005

Snapshot_2 (1).jpg
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,725
Location
Vicksburg Junction, Arizona
Excellent Cameron, glad to hear that.(y)

Thanks for the update!
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top