• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GE PDW9280N20SS Won't fully start Cycle

Status
Not open for further replies.

shamilto

Premium Member
Joined
Apr 11, 2017
Messages
13
Location
MA
Model Number
PDW9280N20SS
Brand
GE
Age
6-10 years
Having a problem with a used GE PDW9280N20SS dishwasher I just purchased for cheap. When I try and start a cycle, I can hear the dishwasher filling, but right before it starts the cycle it beeps and stops. I believe all of the lights go off at this point, either that or just the run light. Restarting it will do the same thing. I should add that I am also unable to select a cycle using the touchpad, though all the other buttons work. This leads me to believe that something may be wrong with the touchpad or the control board, but I figured I would run it by you folks to see which would be the best place to start to keep part replacement costs to a minimum. Any advice would be most appreciated!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,941
Location
McMullen Valley, Arizona

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,941
Location
McMullen Valley, Arizona
That's why I never recommend buying used appliances without testing them first before you hand over the cash.:)

He said it was cheap, but hopefully is was below $50.:)

Jake
 

shamilto

Premium Member
Joined
Apr 11, 2017
Messages
13
Location
MA
Yeah, used appliances can be a gamble. I did actually test the unit before paying out. Worked fine. Something about the uninstall/move seems to have kick-started the issue. I've replaced the touchpad, which fixed the cycle select, but not the original issue. What's strange is that sometimes if I start the cycle a second time it will then begin to run. But then it always eventually stops again soon after. I can try swapping the main board, but I'm also a bit worried it may also be something with the motor.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,941
Location
McMullen Valley, Arizona
The only other part that can cause this problem is the door latch/switch assembly, I'd check that first to make sure its making good contact and the button on the switch is working good.

Here's the door/latch switch assembly for your model:
Door Latch WD13X10031


Jake
 

shamilto

Premium Member
Joined
Apr 11, 2017
Messages
13
Location
MA
Thanks Jake,

I considered this, but if the latch weren't making contact, wouldn't the machine fail to start entirely? Outside of a few times ive gotten it to run for longer than 60 seconds, it starts fine and stops at the exact same point. I would expect a finicky latch to disconnect more sporadically. I'm thinking I will give the replacement board a shot through this site.

~Scott
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,941
Location
McMullen Valley, Arizona
I considered this, but if the latch weren't making contact, wouldn't the machine fail to start entirely?
Not always, it can be intermittent.

I'm thinking I will give the replacement board a shot through this site.
That sounds like a plan.:)

Just wanted to make sure the door switch tested fine.

When you tested the unit before you paid for it was it installed in the kitchen? Mounted in place?

Jake
 

shamilto

Premium Member
Joined
Apr 11, 2017
Messages
13
Location
MA
Just thought I'd report back that the Control Module replacement took care of the problem! Happy to have a working dishwasher again. Appreciate the help!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,941
Location
McMullen Valley, Arizona
Excellent, glad to hear that.:)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top