• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GE Profile Fridge PWE23KMDDES Fridge Not Cooling, Freezer OK, Z1 Blinking Light on Control Board

Status
Not open for further replies.

LivingSouth

Premium Member
Joined
Apr 8, 2021
Messages
8
Location
Georgia
Model Number
PWE23KMDDES
Brand
GE
Age
6-10 years
Hello,

Our PWE23KMMDES GE Profile Energy Star French Door fridge has not been working properly for weeks. The defroster is not working correctly and ice/frost builds up on the evaporator coils in the back of the fridge panel. The fridge will go up to 60 degrees but freezer is fine. We have been getting by by melting the ice/frost off the coils with a hair dryer. Fan is working. Defrost element has been tested and has continuity. We have replaced the evaporator thermistor and thermostat/temperature sensor already. I know there is no manual defrost timer for this model. There is a blinking Z1 light on the control board behind the fridge. Is our solution to replace the mother board? If so, does anyone know the control board model number for this fridge? Does anyone know what the Z1 light blinking means? Google has turned up no results. I don't want to have to buy a new fridge as this one is only 7 years old but it has been so frustrating.

Thank you for any help.
 

Attachments

  • 349A0F9F-860F-4617-8ED8-830F60A284AC.jpeg
    349A0F9F-860F-4617-8ED8-830F60A284AC.jpeg
    523.5 KB · Views: 221
  • 4AD3F56D-6B8C-49B5-A2E1-027355B5A1AC.jpeg
    4AD3F56D-6B8C-49B5-A2E1-027355B5A1AC.jpeg
    322.8 KB · Views: 179
Last edited:

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
44,788
Location
Murray, Utah 84107, United States
Here's the part you need:
 

LivingSouth

Premium Member
Joined
Apr 8, 2021
Messages
8
Location
Georgia
Thank you! I know you can't say for sure, but do you think that the control board is likely the culprit?
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
44,788
Location
Murray, Utah 84107, United States
I know you can't say for sure,
Ahh..but I can. :) There's only three components that make up the defrost system, the defrost heater, defrost thermostat, and the control board. The heater and t-stat test good so that just leaves the control board.
 

LivingSouth

Premium Member
Joined
Apr 8, 2021
Messages
8
Location
Georgia
Thanks again! Ordered the part and will update this thread once I switch out the old control board.
 

LivingSouth

Premium Member
Joined
Apr 8, 2021
Messages
8
Location
Georgia
I just put in the new control board. Z1 light is still blinking on the new control board. Is this of any significance? I can't tell if the fridge is working properly yet but I have read it needs 24 hours for the temperatures to stabilize? Hoping for the best.
 

LivingSouth

Premium Member
Joined
Apr 8, 2021
Messages
8
Location
Georgia
I want to say it's fixed...!!! I changed out the control board Monday and it's now Thursday. Fridge is at 37 to 39, freezer 0 to -2. The most telling sign is there is a layer of frost on the evaporator coil but it's not extremely thick like it was before AND I can see the defrost metal element clearly below. When the defrost was not working, the evaporator coil was caked in layers of frost/ice including the metal defrost element below. Z1 on the control board is still blinking but we never looked at the control board when the fridge was working properly so I can't say if it always blinked regardless. Or we may have another issue to be determined :ROFLMAO: But so far it is working as before. Thank you for your help @rickgburton! Very much appreciated.
 

LivingSouth

Premium Member
Joined
Apr 8, 2021
Messages
8
Location
Georgia
I spoke too soon! There is a ton of frost over the evaporator coils today (Friday). Any ideas?

Also want to add I have been keeping the evaporator cover over the coils.
 

Attachments

  • thumbnail_IMG_2065.jpg
    thumbnail_IMG_2065.jpg
    242.1 KB · Views: 172
Last edited:

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
44,788
Location
Murray, Utah 84107, United States
keeping the evaporator cover over the coils.
Attached with screws and not just leaning on them, correct? OK, recheck the defrost heater for continuity again. Check the defrost thermostat for continuity. I'll see if I can find the tech sheet. Yours should be behind the lower grill probably in an envelope. Can you post a copy here?
 

LivingSouth

Premium Member
Joined
Apr 8, 2021
Messages
8
Location
Georgia
Oops no, I was lazy and didn't attach with screws so I could keep checking. I'll defrost and try again this time attaching it back on correctly. If it frosts up again, will recheck the defrost heater and thermostat for continuity. :oops:
 

LivingSouth

Premium Member
Joined
Apr 8, 2021
Messages
8
Location
Georgia
Update: it’s been over 2 weeks since we properly put back the evaporator cover (screws and all) and the temperature has held steady. 👍🏻🙌🏻 Thanks again for making us aware that the cover has to be on correctly!
 
Status
Not open for further replies.
If you feel that you have benefited from this site, and would like to show your appreciation.
Top