• Please note, some of the links on our site are affiliate links (Learn More)

FIXED GE Refrigerator PSCS3RGXCFSS dispenser not working

Status
Not open for further replies.

Timware2001

Premium Member
Joined
Aug 1, 2021
Messages
4
Location
KS
Model Number
PSCS3RGXCFSS
Brand
GE
Age
6-10 years
Hello, when we push through ice and water dispenser paddle nothing happens. More specifically when the water button is selected nothing happens, but when crushed or cubed ice is selected and pressed, it appears to intermittently short out the display as the lights turns of and the temperature displays go off and come back on for the side by side settings on the display.

The ice machine is still making ice, both the freezer and fridge still work without issue. I checked the connection below the freezer door and it appears fine. Really seems to just short out. Any confidence on what the root cause is and how to fix?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,949
Location
McMullen Valley, Arizona
It sounds more like a motherboard problem.

Pull the refrigerator out from the wall, then unplug it. Then open up the metal access cover on the back cabinet of the refrigerator and behind that cover is your motherboard, look at it closely to see if you notice any burnt or discoloration on that board.

Here's the motherboard for your model:
WR55X10775 Board Asm Main Control


Let us know what you find.

Jake
 

Timware2001

Premium Member
Joined
Aug 1, 2021
Messages
4
Location
KS
Thanks Jake, nothing super obvious to me...only thing that's looks odd is these two chips have a pink and yellow splotches on them, but they don't look burnt up, any thoughts
 

Attachments

  • 20210801_105724.jpg
    20210801_105724.jpg
    545 KB · Views: 38
  • 20210801_105732.jpg
    20210801_105732.jpg
    456 KB · Views: 40

Timware2001

Premium Member
Joined
Aug 1, 2021
Messages
4
Location
KS
Also update, put the cover back on and its (motherboard area) clicking every 3-4 seconds. The display is going in and out with the clicking. Water ran from the dispenser for the split second it appeared to be powered
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,949
Location
McMullen Valley, Arizona
That pink splotch looks its melting the microchip on top, that's not good.

Replace the motherboard and you should be back in business.:)

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,949
Location
McMullen Valley, Arizona
Excellent Tim, glad to hear the new motherboard fixed it.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top