• Please note, some of the links on our site are affiliate links (Learn More)

GFV55ESSN0WW Electric Dryer Won't Heat


Premium Member
May 4, 2020
Model Number
Less than 1 year
Just bought brand new at a scratch & dent 2 weeks ago. Unit had never been used & was completely brand new/untouched with plastic still stuck to it. Unit simply had scratching/wear on the top that I couldn't care less about.

hooked it up at home & it worked perfectly for 3 or 4 loads of drying clothing, then all of a sudden it will no longer heat. Checked circuit breakers and they're fine, not tripped. The machine tumbles fine, just no heat.

In field of service mode it's showing fault codes 1, 2 & 9. Tried replacing both the inlet & outlet thermistors. Didn't change anything. Just ordered a new heating element, but I honestly don't think it will do anything. I took the existing heating element out & looked at it along with the backup thermostat & high limit thermostat hooked up to it, and everything is absolutely brand new. Thermostat 2 is also brand new.

Ran the outlet thermistor test & it doesn't get above 66 degrees. Ran the inlet thermistor test & it goes back & forth between 64 & 63 degrees.

I'm baffled since it worked completely fine for several cycles & then out of nowhere it just stopped.

Anybody have any ideas?

Could it be the personality ID? It's currently set at 7.

Does it need some kind of firmware update?
I found this, looks like 7 is the only ID option for my model


  • f0d7b599-2afd-4924-a385-e7df891c6489_ultrafreshdryermainboard_programming_Rev.1.pdf
    136.8 KB · Views: 38
If the power is correct and you've replaced the parts specified by the fault codes, I can't think of what could cause it besides the electronic control itself. Sorry.

Dan O.
I pulled the power cord from my previous dryer. I've verified that it's connected correctly, but could it still be a problem? If so, how could it have heated for several cycles?
Is the correct board & wiring harness in my unit? It has a J605 connection up next to the J604 wifi board connection that is not shown on the tech sheet, and look at the connections at J302, the tech sheet shows, from left to right, wiring of orange, blue, yellow, black, purple, purple, blue, blue, but the connection in my board, from left to right, the wiring is black, yellow, blue, orange, purple, purple, blue, blue.


  • 20230221_175605.jpg
    257 KB · Views: 25
  • 20230221_175616.jpg
    235 KB · Views: 28
  • 20230221_180005.jpg
    429.7 KB · Views: 23
  • 20230221_180047.jpg
    223.6 KB · Views: 29
  • 20230221_181441.jpg
    232.1 KB · Views: 26
  • 20230221_181446.jpg
    201.1 KB · Views: 26
Also, when I attempt to do any of the show software tests in service mode, when in service mode on tests 3, 4, 5, 6 or 7, when I press the start button nothing happens
I pulled the power cord from my previous dryer. I've verified that it's connected correctly, but could it still be a problem?

If the cord was the problem it would have to stop 240 volts getting to the dryer. A poor connection might only open when under load of use. If 240 volts IS present at the dryer when the dryer should be heating the cord is NOT the problem.

I'm sorry but I can't answer any of your other questions. I don't have a service manual for your model and have no personal experience with it. A GE factory authorized service depot might be required to figure it out.

Dan O.
If you feel that you have benefited from this site, and would like to show your appreciation.