GI15PDXZS0 Whirlpool Ice Maker: No Ice, Dripping In Bin

CylonWolf

Premium Member
Joined
Jan 12, 2019
Messages
4
Location
KY
Model Number
GI15PDXZS0
Brand
Whirlpool
Age
1-5 years
Bought a new house this past year, which included a Whirlpool stand alone ice maker, model GI15PDXZS0 (apparently same as a KitchenAid version). Not sure on actual age, but I believe its less than 5 years old.

Ice appeared to be thin, but as I had nothing to compare it to, I assumed this was standard. Eventually, I needed to clean the ice maker, and removed what parts I could (per manual) and cleaned manually. After replacing everything, the ice maker is not making ice (and ice maker still insists a cleaning is needed). All of the parts have been reinstalled correctly.

When on, it appears that when water comes into the water pan, it immediately drains out and drips off the drain pump and into the ice bin then out of the ice maker (its unclear where exactly this water is leaking from)...almost no water is making it up top to become ice. This is also why I cant run through the actual cleaning process, as the cleaner will just drain out of the machine.

Any idea what may be the issue here, or how I can narrow this down? Any help is greatly appreciated, thanks!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
103,374
Location
McMullen Valley, Arizona
Hi,

Here's the parts diagram for your model: Whirlpool Ice Maker GI15PDXZS0 Repair Parts

I haven't had any experience or training with working on stand alone ice makers, but I will see if our tech. bigbuck has the tech. data sheet for you to go by.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
103,374
Location
McMullen Valley, Arizona
Thanks bigbuck!

CylonWolf: Let us know what you find.

That Service Pointer bigbuck posted sounds like what yours is doing.

Serial Numbers: K514 – K616

Post your serial number and we can see if that one applies to yours.

Jake
 

CylonWolf

Premium Member
Joined
Jan 12, 2019
Messages
4
Location
KY
Hello again, thanks for the help so far!

First thing: I made a mistake on the model number previously; it the midst of lots of Googling, I copied a slightly different model number by mistake. Its actually GI15NDXZS0
The serial number starts with K430, so doesnt fall in that range.

I went through the diagnostics per the first attachment above (its essentially the same model). Everything appears to check out here, as the ice maker responds as indicated.

Regarding the service pointer: this seems to be more about little to no water entering the machine at all. To clarify, the bin does fill with water; it just then drains out of the water bin into the ice bin, and then out of the machine.

Thanks again for your help!
 

CylonWolf

Premium Member
Joined
Jan 12, 2019
Messages
4
Location
KY
Thanks...I think thats pretty much the same as the original though, at least the diagnostic chart is; the diagrams are probably a little above my head at this point.

So I THINK the issue is related to the drain pump potentially. I removed it, and water flows immediately through where it would be. It looks like when attached, the water fills the pump, then leaks out the top of the pump. Maybe I just need a new/better gasket here? The rubber gasket here is relatively small.

Im admittedly relatively clueless here, so this is my best guess based on what I know. Am I completely off base?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
103,374
Location
McMullen Valley, Arizona

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
103,374
Location
McMullen Valley, Arizona
Got it!

Thanks.:)

Jake
 
Top