• Please note, some of the links on our site are affiliate links (Learn More)

GI5FSAXVQ01 Whirlpool Gold Refrigerator - Control Panel Blank

SDavis

Premium Member
Joined
Aug 28, 2020
Messages
4
Location
Oklahoma City
Model Number
GI5FSAXVQ01
Brand
Whirlpool
Age
More than 10 years
I have a 11 Year old Whirlpool Gold - Model GI5FSAXVQ01 and the Control Panel is completely Blank, no lights or codes. the Ice/Water Dispenser does not work. The light in the fridge/freezer do work. not sure if its cooling. I tried tripping the breaker for 10 min per the Owners Manual to 'reset' but did not help.

Please Help!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,971
Location
McMullen Valley, Arizona
Hi,

Yes, the problem is most likely the main control board in the back of your refrigerator.

If you want to verify that to make sure: Check the wires and wire connectors under the top hinge cover. Check if any pins are backing out of the connector. On the main control board measure the voltage at J6-1 and J6-2. If less than +12 Volts DC replace the main control board.

Here's the main control board for your model you can order:
WPW10310240 High Voltage Control Board


If you order it at RepairClinic, You get $60 cash back on your credit card when you return the old one:
Main Control Board WPW10310240


Jake
 

SDavis

Premium Member
Joined
Aug 28, 2020
Messages
4
Location
Oklahoma City
I have replaced the High Voltage Control Board and programmed per the code in the refrigerator. Now it runs for about 30 seconds, the control panel goes blank, then comes back on and starts to cool again and repeat.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,971
Location
McMullen Valley, Arizona
Then you got a defective High Voltage Control Board, where did you get it at?

Jake
 

SDavis

Premium Member
Joined
Aug 28, 2020
Messages
4
Location
Oklahoma City
Ordered it off of Amazon because they could get it to me by today and not sometime next week. I just tried doing the reset and seems to be working. if problem persists, I will return for another. If I order another and have similar issue, any idea of what it could be? Thank you.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,971
Location
McMullen Valley, Arizona
As techs we never buy parts on amazon, we always buy appliances parts from appliance parts dealers only where is plenty of oversight. anyone can sell anything at amazon and say its good, that's why the prices are so cheap there.

Trust me the problem is the High Voltage Control Board you got at amazon.

If you would of ordered it from my link to it above it would work, I just installed the same one last week for a customer in my local area and it worked great!

Jake
 
Top