GNE25JSKCFSS no power to compressor after board replacement

Mrwoods87

Premium Member
Joined
Jun 12, 2019
Messages
2
Location
KC
Model Number
GNE25JSKCFSS
Brand
GE
Age
Less than 1 year
Need some help before I pull my hair out! I have a GNE25JSKCFSS that stopped working. Originally I had no power to the evap or condessor fans. But the compressor was running.i ordered a new control board and installed it, now I have no power to the compressor from the board. The evap and condessor fans work, but no water solenoid power or interior lights. The lights will come on for a second with a audio beep then the lights shut off and wont come on. After you initially plug it in. I have checked the door switches theyre not the problem.

So I am kinda stumped, could i have a bad board out of the box? Or is there something I am missing?
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
33,423
Location
Murray, Utah 84107, United States
Bad board or wrong board. What's the part number of the board you just installed?
 

Mrwoods87

Premium Member
Joined
Jun 12, 2019
Messages
2
Location
KC
I ordered a WR55X26586 part number, the original number on the board is different then the one I ordered. But they said it would work. Top is the new board number and the bottom is old

IMG_08451.jpg
 

Attachments

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
33,423
Location
Murray, Utah 84107, United States
You have the age of the machine listed as less than 1 year. If this is true, stop and call GE. If you attempt a repair you risk losing your warranty.

Check for 120 VAC across the two wires on the compressor.

If the voltage is 0V, replace the board:
 
Top