GTW680BSJ4WS GE Washer going into drain cycle by itself display reads canceled

Royal00star

Premium Member
Joined
May 7, 2019
Messages
3
Location
Delaware
Model Number
GTW680BSJ
Brand
GE
Age
1-5 years
Washer starts and sounds like it’s trying to drain and agitator slightly moves back and forth slowly and the display reads canceled it doesn’t do it after every time we are done doing laundry just once in a while when it does this I unplug the machine till we are ready to do laundry again
 
Last edited by a moderator:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
100,021
Location
McMullen Valley, Arizona
Hi,

We would need the complete model number of your washer. Your missing a digit between the "J" and the "W".

Click here: Appliance Parts

Then you will see a link that says: How to find a model number.

There have been many service bulletins on this model from GE to address these strange problems.

Also What's the serial number of your washer? Then I'll check to see if you have any service bulletins addressing this problem.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
100,021
Location
McMullen Valley, Arizona
Thanks,

The service bulletins don't apply to your model or serial number.

So this only happens once in awhile? When it does this and the drain pump is running do you hear water coming out of the drain hose? If so, how fast is the water coming out? Pull your drain hose up from the drain pipe and watch how fast it drains.

If its slow to drain, that may be causing this problem, I had one do this a few weeks ago, and I tilted the machine back and removed the drain pump, and took the drain pump to the customers sink and flushed it out and reinstalled the drain pump and it fixed it.:)

Here's the drain pump for your model:
WH23X27574 Drain Pump


Jake
 

Royal00star

Premium Member
Joined
May 7, 2019
Messages
3
Location
Delaware
The washer is sitting idle so the tank is empty there is no water to pump out just runs for a couple minutes then shuts off and does the same thing a couple hours later till u unplug the machine
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
100,021
Location
McMullen Valley, Arizona
That's very odd, sounds like a control board problem.

You can order the control board here:
Ui-Mc Board Assy


Jake
 
Top